0 Replies Latest reply on Oct 12, 2018 4:26 AM by Michael Bergin

    Does Wildfly Support Artemis SecuritySettingPlugin or ActiveMQServerPlugin?

    Michael Bergin Newbie

      I'm migrating applications from standalone Artemis to the version embedded in Wildfly.  It doesn't seem like Wildfly's configuration supports Artemis plugins: SecuritySettingPlugin or ActiveMQServerPlugin.  I previously used the security-setting-plugin element in Artemis' broker.xml to configure the SecuritySettingPlugin but that element doesn't seem to be supported in Wildfly's messaging configuration.  Alternatively, I could achieve the required behavior with an ActiveMQServerPlugin which was configured using the broker-plugins element in Artemis' broker.xml but that also doesn't seem to be supported in Wildfly's messaging configuration.  Is there a different way to setup these plugins or is there just no way to use them with Wildfly messaging?