1 Reply Latest reply on Mar 14, 2003 12:12 PM by Roman

    BMP deployment problem: Bean PetBean: found in jboss.xml but

    john ware Newbie

      Hi,
      I am trying to deploy an entity bean in JBoss-2.4.4_Tomcat-4.0.1 and get the following error:

      org.jboss.deployment.DeploymentException: Error in jboss.xml for Bean PetBean: found in jboss.xml but not in ejb-jar.xml

      Here are my ejb-jar.xml and jboss.xml:


      <?xml version="1.0" encoding="ISO-8859-1"?>

      <ejb-jar>
      <display-name>Pets</display-name>

      <enterprise-beans>


      Models a Pet

      <ejb-name>PetBean</ejb-name>
      org.jdware.pet.ejb.entity.PetHome
      org.jdware.pet.ejb.entity.Pet
      <ejb-class>org.jdware.pet.ejb.entity.PetBean</ejb-class>

      <persistence-type>Bean</persistence-type>
      <prim-key-class>java.lang.String</prim-key-class>
      False
      <primkey-field>id</primkey-field>


      </enterprise-beans>

      <assembly-descriptor>
      <container-transaction>

      <ejb-name>PetBean</ejb-name>
      <method-name>*</method-name>

      <trans-attribute>Required</trans-attribute>
      </container-transaction>

      </assembly-descriptor>
      </ejb-jar>
      <?xml version="1.0" encoding="ISO-8859-1"?>



      <enterprise-beans>

      <ejb-name>PetBean</ejb-name>
      <jndi-name>org.jdware.pet.ejb.entity.Pet</jndi-name>

      </enterprise-beans>



      <cache-policy>org.jboss.ejb.plugins.NoPassivationCachePolicy</cache-policy>






      If anyone has seen this before and found the solution I will greatly appreciate the help.

      thanks

      john ware
      boulder co