2 Replies Latest reply on Dec 29, 2018 8:31 AM by Erik .

    Warning message on /subsystem=transactions

    Angela Ho Novice

      Hi all,

       

      While starting the wildfly 11 app server for my system, i encountered this warning message logged in the server.log.

       

      WARN [org.jboss.as.txn] (ServerService Thread Pool -- 58) WFLYTX0013: The node-identifier attribute on the /subsystem=transactions is set to the default value. This is a danger for environments running multiple servers. Please make sure the attribute value is unique.

       

      Is there any configuration settings we need to do on standalone.xml?

       

      Appreciate any kind advice.

        • 1. Re: Warning message on /subsystem=transactions
          Alban Chadenas Newbie

          Hi Angela,

           

          You can set a unique value for your instance in the standalone configuration, default value is 1:

          <subsystem xmlns="urn:jboss:domain:transactions:5.0">
            <core-environment node-identifier="${jboss.tx.node.id:1}">
            ...
          </subsystem>

          Alternatively, you can pass a unique value to the server as a JVM parameter:

          -Djboss.tx.node.id=my-unique-server-id

          The choice is yours and you should no longer see the warning when starting the server.

          • 2. Re: Warning message on /subsystem=transactions
            Erik . Newbie

            An other option is to set ${jboss.tx.node.id} in a system-property.

             

            For a standalone configurationyou can set node id value through cli in a system-property

            ./system-property=jboss.tx.node.id:add(value=111)

            or in standalone.xml

            <server xmlns="urn:jboss:domain:9.0">
                ...
                <system-properties>
                    <property name="jboss.tx.node.id" value="111"/>
                </system-properties>
                ...
            </server>
            

             

            For a domain configuration you can set node id value through cli in a system-property for each server. Just as what was written in a previous topic about this subject Re: JBAS010153: Node identifier property is set to the default value. Please make sure it is unique.

            ./host=master/server-config=server-one/system-property=jboss.tx.node.id:add(boot-time=true,value=101)
            ./host=master/server-config=server-two/system-property=jboss.tx.node.id:add(boot-time=true,value=102)
            

            or in host.xml

            <host xmlns="urn:jboss:domain:9.0" ...>
                ...
                <servers>
                    <server name="server-one" ...>
                        <system-properties>
                            <property name="jboss.tx.node.id" value="101" boot-time="true"/>
                        </system-properties>
                        ...
                    </server>
                    <server name="server-two" ...>
                        <system-properties>
                            <property name="jboss.tx.node.id" value="102" boot-time="true"/>
                        </system-properties>
                        ...
                    </server>
                    ...
                </servers>
                ...
            </host>