1 Reply Latest reply on Dec 26, 2018 12:11 PM by Kenneth Christensen

    How to avoid warning "Invalid "host" value "0.0.0.0" detected for "http-connector" connector."?

    Frank Langelage Master

      Starting Wildfly I see this message:

      26.12. 01:10:54,058 WARN  [org.apache.activemq.artemis.jms.server#correctInvalidNettyConnectorHost] AMQ122005: Invalid "host" value "0.0.0.0" detected for "http-connector" connector. Switching to "sb2000". If this new address is incorrect please manually configure the connector to use the proper one.

      Appears with Wildfly 15 as well as with older versions.

       

      The http-connector named "http-connector" within the messaging-activemq subsytem is defined with "socket-binding="http"" like in orginal standalone-full.xml:

      <http-connector name="http-connector" socket-binding="http" endpoint="http-acceptor"/>

       

      Acceptor def is

      <http-acceptor name="http-acceptor" http-listener="default"/>

       

      And socket-binding definition also was not changed:

      <socket-binding name="http" port="${jboss.http.port:8080}"/>

       

      What was changed is the the public interface definition:

      <interface name="public">

          <any-address/>

      </interface>

       

      I'd like to avoid this warning. What to do to get rid of it?

       

      The default http-listener must be bound to all interfaces of the server, not to a single one represented by a host name. For this purpose "<any-address/>" was chosen.

      For the activemq subsystem it would be sufficient to to use the primary host name or even localhost as it's host value. Remote access is not required.

      wildfly-messaging-activemq_6_0.xsd does not contain any host attribute.

        • 1. Re: How to avoid warning "Invalid "host" value "0.0.0.0" detected for "http-connector" connector."?
          Kenneth Christensen Novice

          To get rid of the warning message, I created a new socket-binding and http-listener.

           

          E.g.:

           

          <subsystem xmlns="urn:jboss:domain:messaging-activemq:5.0">

          ...

          ...

              <http-connector name="http-connector" socket-binding="activemq" endpoint="http-acceptor"/>

              <http-connector name="http-connector-throughput" socket-binding="activemq" endpoint="http-acceptor-throughput">

          ...

          ...

              <http-acceptor name="http-acceptor" http-listener="activemq"/>

              <http-acceptor name="http-acceptor-throughput" http-listener="activemq">

          ...

          ...

          </subsystem>

           

          <subsystem xmlns="urn:jboss:domain:undertow:8.0" default-server="default-server" default-virtual-host="default-host" default-servlet-container="default" default-security-domain="other">

          ...

          ...

              <http-listener name="activemq" socket-binding="activemq" enable-http2="true"/>

          ...

          ...

          </subsystem>

           

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

          ...

          ...

              <socket-binding name="activemq" interface="private" port="${jboss.activemq.port:8081}"/>

          ...

          ...

          </subsystem>

           

          As you can see, the socket-binding binds to the private interface and port 8081.

           

          It works for me :-)