0 Replies Latest reply on Jan 17, 2019 12:53 PM by David Bailey

    JBoss Data Virt Access Using SSL

    David Bailey Newbie

      I have Data Virt running via the standalone.sh script, and can log in with my username and password. My next task is configuring it so that it automatically runs whenever the instance is up and running (without having to execute standalone.sh), and uses SSL (port 443) rather than my username and password to log me in. I added the vault.keystore, dv_keystore.jks, and dv_truststore.jks files, and modified both standalone.sh and standalone.xml, according to the JBoss and other online documentation, to account for using these files. I start the standalone.sh script, which runs without any errors. When I browse to:

       

      http://<IP>:8443/dashboard

       

      after starting standalone.sh, I get the following error:

       

           This page can't be displayed

           Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://:8443 again. If this error persists, it is possible that this site uses an unsupported protocol or      cipher suite such as RC4, which is not considered secure. Please contact your site administrator.

       

      The settings Use TLS-1.0-ON, Use TLS-1.1-ON, and Use TLS-1.2-ON are all checked in the Browser properties.

      By contrast, when I browse to:

      http://<IP>:8443/dashboard

      when standalone.sh is not running, I get the following:

           This page can't be displayed

      • Make sure the web address https://:8443 is correct.
      • Look for the page with your search engine.
      • Refresh the page in a few minutes.

       

      It appears the browser is sensing something going on when standalone.sh is running, but something is not allowing the browser to access the dashboard.  What am I missing here?