6 Replies Latest reply on Feb 11, 2019 8:57 AM by Ray M

    Can't access to admin console after forcing wildfly 14 to use ssl on the port 443

    Ray M Newbie

      I'm new to the wildfly world and this is my fist time that I use it in my courses and I'm trying to deploy during my traineeship in the work environment.

      So I deployed wildfly to my server on a subdomain and Nginx is a reverse proxy.To secure my connection I forced wildfly to use https through 443 with a letsencrypt ssl certificate :

      In the standalone.xml, I create an additional socket-binding entry. and I added a

      <socket-binding name="https-external" port="443"/> 

      and I Changed the http-listener to redirect this https-external instead https.

      It worked fine until the moment when I tried to access the admin console: I was unable to login.

      I tried to modify the management-interfaces by adding a socket-binding with http="management-https"(and by default it uses the port 9993 for the management-https) but it didn't work. It looks that I'm missing something which I can't figure out. 

      the content of the "vhost" file of wildfly subdomain for ngnix is :

      upstream wildflyadmin { 
      server; }
      upstream wildfly {
      server; }
      server {
      server_name sub.domaine.com; 
      access_log  /var/log/nginx/wildfly.access.log; error_log  
      proxy_buffers 16 64k; proxy_buffer_size 128k; 
      location / { proxy_pass http://wildfly; } 
      location /dashadmin/ { proxy_pass http://wildflyadmin; } 
      listen 443 ssl; # managed by Certbot ssl_certificate
      /etc/letsencrypt/live/domaine.com/fullchain.pem; # managed by Certbot
      ssl_certificate_key /etc/letsencrypt/live/domaine.com/privkey.pem; # managed by Certbot include
      /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
      ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot }