1 Reply Latest reply on Feb 25, 2019 4:50 AM by Arnav Bhati

    Disable sync for specific entries in replicated-cache (Infinispan)

    Jayaprabahar Chandrasekaran Newbie

      Hi,

       

      I am using replicated-cache to sync entries of Infinispan cache that is running on 2 Docker images. I face some technical problems, so I would like to disable sync for a specific cache entry.

      How to perform this.

       

      My config will look like this,

       

              <subsystem xmlns="urn:jboss:domain:infinispan:4.0">

                  <cache-container name="applnCache" default-cache="replCache" statistics-enabled="true">

                      <transport lock-timeout="60000"/>

                      <replicated-cache name="replCache" jndi-name="java:jboss/infinispan/replCache" statistics-enabled="true" mode="SYNC">

                          <locking isolation="REPEATABLE_READ"/>

                          <transaction mode="NON_XA"/>

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration lifespan="604800"/>

                          <file-store path="replCache" passivation="false" preload="true" purge="false" shared="false"/>

                      </replicated-cache>

                  </cache-container>

           </subsystem>