3 Replies Latest reply on Mar 21, 2019 4:09 AM by simkam

    Wildfly 15 ignoring encoding settings in standalone-full.xml?

    Markus Fried Newbie

      Hi,

       

      Out legacy project (currently running on Weblogic) uses ISO-8859-15 encodings, so I've got the following settings in standalone-full.xml for Wildfly 15:

       

      <server name="default-server">
        
      <http-listener name="default" socket-binding="http" url-charset="ISO-8859-15" redirect-socket="https" enable-http2="true"/>
        
      <https-listener name="https" socket-binding="https" url-charset="ISO-8859-15" security-realm="ApplicationRealm" enable-http2="true"/>
      ...
      <servlet-container name="default" default-encoding="ISO-8859-15" use-listener-encoding="true">

       

      Unfortunately this does not seem to be enough, in the browser I can see the response header for content-type as "text/html; charset=UTF-8", which leads to all kinds of problems with special characters like german umlauts in my ISO-8859-15 encoded (thousands of them) files.

       

      What am I missing, where is the correct place to change the encoding that wildfly uses?

       

      Best regards

       

      Mark.