2 Replies Latest reply on Mar 27, 2019 4:36 AM by Michael Burman

    can't start rhq-agent.sh

    Mehrdad Mehrdad Newbie

      Hi

      I try to install rhq-agent.sh on a machine but when I execute this script below error appear, any idea?

       

      [root@rhel bin]# ./rhq-agent.sh

      [root@rhel bin]# RHQ 4.13.0 [07169c1]

      Answer the following questions to setup this RHQ Agent instance.

      - After each prompt, a default value will appear in square brackets.

        If you press the ENTER key without providing any value,

        the new preference value will be set to that default value.

      - If you wish to rely on the system internal default value and

        not define any preference value, enter '!*'.

      - If you wish to stop before finishing all the questions but still

        retain those preferences you already set, enter '!+'.

      - If you wish to cancel before finishing all the questions and revert

        all preferences back to their original values, enter '!-'.

      - If you need help for a particular preference, enter '!?'.

       

      Agent Name [localhost] : Failed to start the agent

      java.lang.NullPointerException

              at org.rhq.enterprise.communications.util.prefs.Setup.prompt(Setup.java:303)

              at org.rhq.enterprise.communications.util.prefs.Setup.setup(Setup.java:193)

              at org.rhq.enterprise.agent.promptcmd.SetupPromptCommand.performBasicSetup(SetupPromptCommand.java:108)

              at org.rhq.enterprise.agent.AgentMain.main(AgentMain.java:455)

      Agent will be restarted soon to see if the failure condition cleared up

       

       

       

       

      FYI:

      1-java home path set in this file "rhq-agent-env.sh" for below value:

      RHQ_JAVA_HOME="/usr/lib/jvm/jre-1.8.0-openjdk.x86_64"

       

      2-set server ip in "agent-configuration.xml" file for below values:

      "rhq.agent.server.bind-address"

      "rhq.communications.connector.bind-address"

      "serverBindAddress"

       

       

      Thanks,