1 Reply Latest reply on Apr 13, 2019 4:34 AM by Frank Langelage

    Unable to deploy application due to org.jboss.modules.ModuleNotFoundException

    Tapas Ranjan Newbie

      Hi Guys,

       

      I am unable to start my application in Red Hat Jboss EAP 7.1.1 due to the Module-Not-Found exception.

       

      The error logs are as follows.

      Please provide me your valuable suggestions to fix this issue.

       

      11:20:39,334 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC000001: Failed to start service jboss.module.service."deployment.helloForm.war".main: org.jboss.msc.service.StartException in service jboss.module.service."deployment.HelloForm.war".main: WFLYSRV0179: Failed to load module: deployment.HelloForm.war

             at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:91)

             at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:2032)

             at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1955)

             at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)

             at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)

             at java.lang.Thread.run(Thread.java:748)

      Caused by: org.jboss.modules.ModuleNotFoundException: org.springframework.spring:5.0.2

             at org.jboss.modules.Module.addPaths(Module.java:1217)

             at org.jboss.modules.Module.link(Module.java:1573)

             at org.jboss.modules.Module.relinkIfNecessary(Module.java:1601)

             at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:287)

             at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:271)

             at org.jboss.as.server.moduleservice.ModuleLoadService.start(ModuleLoadService.java:68)

             ... 5 more

      11:20:39,347 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) WFLYCTL0013: Operation ("deploy") failed - address: ([("deployment" => "HelloForm.war")]) - failure description: {"WFLYCTL0080: Failed services" => {"jboss.module.service.\"deployment.HelloForm.war\".main" => "WFLYSRV0179: Failed to load module: deployment.HelloForm.war

          Caused by: org.jboss.modules.ModuleNotFoundException: org.springframework.spring:5.0.2"}}

      11:20:39,392 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 37) WFLYSRV0010: Deployed "HelloForm.war" (runtime-name : "HelloForm.war")

      11:20:39,394 INFO  [org.jboss.as.controller] (Controller Boot Thread) WFLYCTL0183: Service status report

      WFLYCTL0186:   Services which failed to start:      service jboss.module.service."deployment.HelloForm.war".main: WFLYSRV0179: Failed to load module: deployment.HelloForm.war

       

       

      11:20:39,709 INFO  [org.jboss.as.server] (Controller Boot Thread) WFLYSRV0212: Resuming server

      11:20:39,712 INFO  [org.jboss.as] (Controller Boot Thread) WFLYSRV0060: Http management interface listening on http://127.0.0.1:9990/management

      11:20:39,713 INFO  [org.jboss.as] (Controller Boot Thread) WFLYSRV0051: Admin console listening on http://127.0.0.1:9990

      11:20:39,714 ERROR [org.jboss.as] (Controller Boot Thread) WFLYSRV0026: JBoss EAP 7.1.0.GA (WildFly Core 3.0.10.Final-redhat-1) started (with errors) in 11338ms - Started 317 of 580 services (2 services failed or missing dependencies, 351 services are lazy, passive or on-demand)

       

       

      Thanks & regards

      Tapas ranjan