2 Replies Latest reply on Feb 8, 2002 8:11 AM by Chris

    remote client

    Chris Newbie

      Hi,

      I followed the JBoss online-manual for "Coding & Compiling the test client".

      This works fine from the Solaris machine that also runs JBoss.

      But the moment I run it on a remote machine (on the same local network...so no Firewall) I get a Socket Exception:
      code=10051 (NT)
      or
      errno:128 (UNIX)

      This happens whether I connect using the hostname or the IP address though I can ping both just fine.

      Could this be a problem with jnp protocol?
      Or more likely to do with NIS having a different IP address for that machine?

      Any ideas on any configuration I have missed or something else that is obvious?

      Thanks in advance

      Chris
      -=-=-=

      -=-=-=-=-=-=-

      javax.naming.CommunicationException. Root exception is java.rmi.ConnectIOExce
      is:
      java.net.SocketException: connect (code=10051)
      java.net.SocketException: connect (code=10051)
      at java.net.PlainSocketImpl.socketConnect(Native Method)
      at java.net.PlainSocketImpl.doConnect(Unknown Source)
      at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
      at java.net.PlainSocketImpl.connect(Unknown Source)
      at java.net.Socket.(Unknown Source)
      at java.net.Socket.(Unknown Source)
      at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown
      at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown
      at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
      at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
      at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
      at sun.rmi.server.UnicastRef.invoke(Unknown Source)
      at org.jnp.server.NamingServer_Stub.lookup(Unknown Source)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:365)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:349)
      at javax.naming.InitialContext.lookup(Unknown Source)

        • 1. Re: remote client
          Adrian Brock Master

          This error is network unreachable.

          Other people have reported problems when the ip
          configuration is wrong for the server, either in the
          host table or the dns. RMI doesn't seem very
          tolerant.
          You can check this by adding the following
          parameter to the java command in run.sh

          -Djava.rmi.server.hostname

          RMI then uses host names instead of trying to
          determine an IP address for the server.

          If this fixes your problem, check your ip configuration,
          or just continue to use host names :-)

          Regards,
          Adrian

          • 2. Re: remote client
            Chris Newbie

            Thanks for the reply....*much* appreciated....

            adding that line worked a treat.....

            it seems that the host in question has multiple IP addresses for different circumstances.....

            Chris
            -=-=-=