1 Reply Latest reply on Sep 2, 2019 11:08 AM by Galder Zamarreño

    Cannot find a parser for element 'cli-loader' in namespace 'urn:infinispan:config:store:cli:7.2'

    4444ss cheng Newbie

      I want to migrate the data using cli-loader but got error message

       

      Cannot find a parser for element 'cli-loader' in namespace 'urn:infinispan:config:store:cli:7.2'. Check that your configuration is up-to date for this version of Infinispan.

       

      here is my config file

       

      <?xml version="1.0" encoding="UTF-8"?>
      <infinispan
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="urn:infinispan:config:7.2 http://www.infinispan.org/schemas/infinispan-config-7.2.xsd
        urn:infinispan:config:store:cli:7.2 http://www.infinispan.org/schemas/infinispan-cacheloader-cli-config-7.2.xsd
        urn:infinispan:config:store:jdbc:7.2 http://www.infinispan.org/schemas/infinispan-cachestore-jdbc-config-7.2.xsd"
         xmlns="urn:infinispan:config:7.2"
         xmlns:cli="urn:infinispan:config:store:cli:7.2">
        <cache-container default-cache="default">
        <local-cache name="persisted_repository">
        <persistence>
        <cli-loader xmlns="urn:infinispan:config:store:cli:7.2" connection="jmx://localhost:8777/DefaultCacheManager/persisted_repository" />
        </persistence>
        <transaction
         transaction-manager-lookup="org.infinispan.transaction.lookup.GenericTransactionManagerLookup"
         mode="BATCH" locking="OPTIMISTIC" />
        </local-cache>

        </cache-container>
      </infinispan>