6 Replies Latest reply on Aug 21, 2019 6:49 AM by Thomas Jenkinson

    Rename lra-filters to narayana-lra

    Martin Stefanko Newbie

      Hi,

       

      as lra-filters is the main (and only) dependency that users will typically come in contact with when using Narayana LRA implementation, it would be beneficial for it to have a generic name to avoid questions like why do I need to include lra-filters and not lra-client? It's easier to explain and read:

       

       

      <dependency>

        <groupId>org.eclipse.microprofile.lra</groupId>

        <artifactId>microprofile-lra-api</artifactId>

        <version>1.0-RC1</version>

      </dependency>

       

      <dependency>

        <groupId>org.jboss.narayana.rts</groupId>

        <artifactId>narayana-lra</artifactId>

        <version>5.9.6.Final</version>

      </dependency>

       

       

      While this can lead to unwanted questions and misunderstandings:

       

       

      <dependency>

        <groupId>org.eclipse.microprofile.lra</groupId>

        <artifactId>microprofile-lra-api</artifactId>

        <version>1.0-RC1</version>

      </dependency>

       

      <dependency>

        <groupId>org.jboss.narayana.rts</groupId>

        <artifactId>lra-filters</artifactId>

        <version>5.9.6.Final</version>

      </dependency>