12 Replies Latest reply on Sep 19, 2019 3:24 PM by Tomaž Cerar

    Enabling manual deployment

    Greg Brown Newbie

      I'm currently profiling a Wildfly 17 instance to try to identify some application bottlenecks, and I'm seeing what appears to be some strange file system monitoring behavior. When the application server starts up, something appears to create an instance of WindowsWatchService that ends up consuming quite a bit of CPU time. I can't tell if this is impacting overall application performance or not, so I want to try to disable it.

       

      I thought it might be caused by the deployment scanner, so I tried removing the deployment scanner subsystem from standalone.xml. This seems to resolve the problem, but it also prevents my app from deploying. I suspect that I need to enable manual deployment mode; however, I haven't been able to find any clear documentation on how to do this (I have seen a lot of docs that reference manual mode, but none with examples of how to actually do it).

       

      Here is how I have currently configured the deployment scanner:

       

              <subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">

                  <deployment-scanner path="deployments" relative-to="jboss.server.base.dir"

                      scan-enabled="false" scan-interval="0"

                      auto-deploy-zipped="false" auto-deploy-exploded="false"

                      runtime-failure-causes-rollback="${jboss.deployment.scanner.rollback.on.failure:false}" />

              </subsystem>

       

      In wildfly-17.0.0.Final\standalone\deployments, I have an exploded EAR folder (foo.ear) and a foo.ear.dodeploy file. However, when I start the server, my EAR is not deployed.

       

      What am I doing wrong?

       

      Thanks,

      Greg