8 Replies Latest reply on Nov 14, 2019 5:21 AM by MeenakshiSundaram R

    Activemq remote JMS Connection does not working

    MeenakshiSundaram R Newbie

      Hi,

       

      I am using wildfly 14 server  and activemq for JMS remote server communication.  I am getting  an error during remote jms communication( AMQ214016: Failed to create netty connection: javax.net.ssl.SSLException: handshake timed out    at io.netty.handler.ssl.SslHandler.handshake

       

      Stanalone-full.xml configuration

      <subsystem xmlns="urn:jboss:domain:messaging-activemq:4.0">

            <server name="default" persistence-enabled="true">

              <journal type="NIO" min-files="2"/>

              <remote-connector name="netty" socket-binding="messaging"/>

                      <param name="ssl-enabled" value="true"/>

                      <param name="key-store-path" value="/java/jre/lib/security/cacerts"/>

                      <param name="key-store-password" value="****"/>

              </remote-connector>

              <remote-connector name="netty-throughput" socket-binding="messaging-throughput">

                     <param name="ssl-enabled" value="true"/>

                      <param name="key-store-path" value="//java/jre/lib/security/cacerts"/>

                     <param name="key-store-password" value="*****"/>

           </remote-connector>

              <in-vm-connector name="in-vm" server-id="0"/>

              <connector name="remote-activemq-nonmanaged" socket-binding="activemq-messaging" factory-class="org.apache.activemq.artemis.core.remoting.impl.netty.NettyConnectorFactory"/>

              <remote-acceptor name="netty" socket-binding="messaging"/>

              <remote-acceptor name="netty-throughput" socket-binding="messaging-throughput">

                <param name="batch-delay" value="50"/>

              </remote-acceptor>

              <in-vm-acceptor name="in-vm" server-id="0"/>

              <security-setting name="#">

                <role name="admin" send="true" consume="true" create-durable-queue="false" delete-durable-queue="false" create-non-durable-queue="false" delete-non-durable-queue="false" manage="true"/>

                <role name="guest" send="true" consume="true" create-durable-queue="false" delete-durable-queue="false" create-non-durable-queue="true" delete-non-durable-queue="true" manage="false"/>

              </security-setting>

              <address-setting name="#" dead-letter-address="jms.queue.DLQ" expiry-address="jms.queue.ExpiryQueue" redelivery-delay="0" max-size-bytes="1048576" page-size-bytes="2097152" address-full-policy="PAGE" message-counter-history-day-limit="10" last-value-queue="true"/>

              <connection-factory name="InVmConnectionFactory" entries="java:/ConnectionFactory" connectors="in-vm"/>

              <connection-factory name="RemoteConnectionFactory" entries="java:jboss/exported/jms/RemoteConnectionFactory" connectors="netty"/>

              <pooled-connection-factory name="activemq-ra" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory" connectors="in-vm" transaction="xa"/>

         </server>

      </subsystem>

       

      Thanks,

      MS

        • 1. Re: Activemq remote JMS Connection does not working
          ehugonnet Expert

          Is your certificate trusted ? Maybe you should define a trustore ?

          • 2. Re: Activemq remote JMS Connection does not working
            MeenakshiSundaram R Newbie

            Thanks Ehugonnet. I generated self-signed certificate and imported the certificate into //java/jre/lib/security/cacerts

            • 3. Re: Activemq remote JMS Connection does not working
              ehugonnet Expert

              so you need to define your trusture in your netty-connector configuration

              • 4. Re: Activemq remote JMS Connection does not working
                MeenakshiSundaram R Newbie

                Defined the trust store configuration in netty-connector but still getting the same error.

                 

                <param name="truest-store-path" value="/java/jre/lib/security/truststore.jks"/>

                <param name="truest-store-password" value="**"/>

                • 5. Re: Activemq remote JMS Connection does not working
                  ehugonnet Expert

                  Your param names are wrong: you should use "trust-store-path"  and "trust-store-password"

                  • 6. Re: Activemq remote JMS Connection does not working
                    MeenakshiSundaram R Newbie

                    Thanks for your  support.  I corrected the typo error but it didn't solve the problem.

                     

                    <param name="trust-store-path" value="/java/jre/lib/security/truststore.jks"/>

                    <param name="trust-store-password" value="**"/>

                    • 7. Re: Activemq remote JMS Connection does not working
                      ehugonnet Expert

                      Alas without further details i can't help you in this. Maybe you should try to trace the SSL exchanges like here :Debugging SSL/TLS connections

                      • 8. Re: Activemq remote JMS Connection does not working
                        MeenakshiSundaram R Newbie

                        Please find the complete standalone-full.xml file configuration details below.  Also  set  the system properties  during the server startup Djavax.net.debug=all, -Djavax.net.ssl.trustStore="/java/jre/lib/security/truststore.jks but still getting the SSL Handshake error

                         

                        <?xml version="1.0"?>

                        <server xmlns="urn:jboss:domain:8.0">

                          <extensions>

                            <extension module="org.jboss.as.clustering.infinispan"/>

                            <extension module="org.jboss.as.connector"/>

                            <extension module="org.jboss.as.deployment-scanner"/>

                            <extension module="org.jboss.as.ee"/>

                            <extension module="org.jboss.as.ejb3"/>

                            <extension module="org.jboss.as.jaxrs"/>

                            <extension module="org.jboss.as.jdr"/>

                            <extension module="org.jboss.as.jmx"/>

                            <extension module="org.jboss.as.jpa"/>

                            <extension module="org.jboss.as.jsf"/>

                            <extension module="org.jboss.as.jsr77"/>

                            <extension module="org.jboss.as.logging"/>

                            <extension module="org.jboss.as.mail"/>

                            <extension module="org.jboss.as.naming"/>

                            <extension module="org.jboss.as.pojo"/>

                            <extension module="org.jboss.as.remoting"/>

                            <extension module="org.jboss.as.sar"/>

                            <extension module="org.jboss.as.security"/>

                            <extension module="org.jboss.as.transactions"/>

                            <extension module="org.jboss.as.webservices"/>

                            <extension module="org.jboss.as.weld"/>

                            <extension module="org.wildfly.extension.batch.jberet"/>

                            <extension module="org.wildfly.extension.core-management"/>

                            <extension module="org.wildfly.extension.discovery"/>

                            <extension module="org.wildfly.extension.ee-security"/>

                            <extension module="org.wildfly.extension.elytron"/>

                            <extension module="org.wildfly.extension.io"/>

                            <extension module="org.wildfly.extension.messaging-activemq"/>

                            <extension module="org.wildfly.extension.microprofile.config-smallrye"/>

                            <extension module="org.wildfly.extension.microprofile.health-smallrye"/>

                            <extension module="org.wildfly.extension.microprofile.opentracing-smallrye"/>

                            <extension module="org.wildfly.extension.request-controller"/>

                            <extension module="org.wildfly.extension.security.manager"/>

                            <extension module="org.wildfly.extension.undertow"/>

                            <extension module="org.wildfly.iiop-openjdk"/>

                          </extensions>

                          <management>

                            <security-realms>

                              <security-realm name="ManagementRealm">

                                <authentication>

                                  <local default-user="$local" skip-group-loading="true"/>

                                  <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                                </authentication>

                                <authorization map-groups-to-roles="false">

                                  <properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>

                                </authorization>

                              </security-realm>

                              <security-realm name="UndertowRealm">

                                <server-identities>

                                  <ssl>

                                    <keystore path="application.keystore" relative-to="jboss.server.config.dir" keystore-password="password" alias="server" key-password="password" generate-self-signed-certificate-host="localhost"/>

                                  </ssl>

                                </server-identities>

                              </security-realm>

                              <security-realm name="ApplicationRealm">

                                <server-identities>

                                  <ssl>

                                    <keystore path="application.keystore" relative-to="jboss.server.config.dir" keystore-password="password" alias="server" key-password="password" generate-self-signed-certificate-host="localhost"/>

                                  </ssl>

                                </server-identities>

                                <authentication>

                                  <local default-user="$local" allowed-users="*" skip-group-loading="true"/>

                                  <properties path="application-users.properties" relative-to="jboss.server.config.dir"/>

                                </authentication>

                                <authorization>

                                  <properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                                </authorization>

                              </security-realm>

                            </security-realms>

                            <audit-log>

                              <formatters>

                                <json-formatter name="json-formatter"/>

                              </formatters>

                              <handlers>

                                <file-handler name="file" formatter="json-formatter" path="audit-log.log" relative-to="jboss.server.data.dir"/>

                              </handlers>

                              <logger log-boot="true" log-read-only="false" enabled="false">

                                <handlers>

                                  <handler name="file"/>

                                </handlers>

                              </logger>

                            </audit-log>

                            <management-interfaces>

                              <http-interface security-realm="ManagementRealm">

                                <http-upgrade enabled="true"/>

                                <socket-binding http="management-http"/>

                              </http-interface>

                            </management-interfaces>

                            <access-control provider="simple">

                              <role-mapping>

                                <role name="SuperUser">

                                  <include>

                                    <user name="$local"/>

                                  </include>

                                </role>

                              </role-mapping>

                            </access-control>

                          </management>

                          <profile>

                            <subsystem xmlns="urn:jboss:domain:logging:6.0">

                              <console-handler name="CONSOLE">

                                <level name="INFO"/>

                                <formatter>

                                  <pattern-formatter pattern="[%d{MM/dd/yy HH:mm:ss:sss z}] %5p %.13c{1} (%t): %m%n"/>

                                </formatter>

                              </console-handler>

                              <custom-handler name="FILE" class="org.jboss.logmanager.handlers.PeriodicSizeRotatingFileHandler" module="org.jboss.logmanager">

                                <level name="INFO"/>

                                <formatter>

                                  <pattern-formatter pattern="[%d{MM/dd/yy HH:mm:ss:sss z}] %5p %.13c{1} (%t): %m%n"/>

                                </formatter>

                                <properties>

                                  <property name="fileName" value="${jboss.server.log.dir}/server.log"/>

                                  <property name="rotateSize" value="20971520"/>

                                  <property name="maxBackupIndex" value="50"/>

                                  <property name="append" value="true"/>

                                  <property name="suffix" value=".yyyy-MM-dd"/>

                                  <property name="autoFlush" value="true"/>

                                </properties>

                              </custom-handler>

                              <logger category="com.arjuna">

                                <level name="WARN"/>

                              </logger>

                              <logger category="org.jboss.as.config">

                                <level name="DEBUG"/>

                              </logger>

                              <root-logger>

                                <level name="INFO"/>

                                <handlers>

                                  <handler name="CONSOLE"/>

                                  <handler name="FILE"/>

                                </handlers>

                              </root-logger>

                              <formatter name="PATTERN">

                                <pattern-formatter pattern="%d{yyyy-MM-dd HH:mm:ss,SSS} %-5p [%c] (%t) %s%e%n"/>

                              </formatter>

                              <formatter name="COLOR-PATTERN">

                                <pattern-formatter pattern="%K{level}%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%e%n"/>

                              </formatter>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:batch-jberet:2.0">

                              <default-job-repository name="in-memory"/>

                              <default-thread-pool name="batch"/>

                              <job-repository name="in-memory">

                                <in-memory/>

                              </job-repository>

                              <thread-pool name="batch">

                                <max-threads count="10"/>

                                <keepalive-time time="30" unit="seconds"/>

                              </thread-pool>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:core-management:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:datasources:5.0"/>

                            <subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">

                              <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" runtime-failure-causes-rollback="${jboss.deployment.scanner.rollback.on.failure:false}"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:discovery:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:ee:4.0">

                              <global-modules>

                                <module name="com.oracle.ojdbc6" slot="main"/>

                                <module name="org.jboss.ironjacamar.jdbcadapters" slot="main"/>

                              </global-modules>

                              <spec-descriptor-property-replacement>false</spec-descriptor-property-replacement>

                              <jboss-descriptor-property-replacement>true</jboss-descriptor-property-replacement>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:ee-security:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:ejb3:5.0">

                              <session-bean>

                                <stateless>

                                  <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                                </stateless>

                                <stateful default-access-timeout="5000" cache-ref="simple" passivation-disabled-cache-ref="simple"/>

                                <singleton default-access-timeout="5000"/>

                              </session-bean>

                              <mdb>

                                <resource-adapter-ref resource-adapter-name="${ejb.resource-adapter-name:activemq-ra.rar}"/>

                                <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                              </mdb>

                              <pools>

                                <bean-instance-pools>

                                  <strict-max-pool name="mdb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                                  <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                                </bean-instance-pools>

                              </pools>

                              <caches>

                                <cache name="simple" aliases="NoPassivationCache"/>

                                <cache name="passivating" passivation-store-ref="file" aliases="SimpleStatefulCache"/>

                              </caches>

                              <passivation-stores>

                                <file-passivation-store name="file"/>

                              </passivation-stores>

                              <async thread-pool-name="default"/>

                              <timer-service thread-pool-name="default" default-data-store="default-file-store">

                                <data-stores>

                                  <file-data-store name="default-file-store" path="timer-service-data" relative-to="jboss.server.data.dir"/>

                                </data-stores>

                              </timer-service>

                              <remote connector-ref="http-remoting-connector" thread-pool-name="default">

                                <channel-creation-options>

                                  <option name="READ_TIMEOUT" value="${prop.remoting-connector.read.timeout:20}" type="xnio"/>

                                  <option name="MAX_OUTBOUND_MESSAGES" value="1234" type="remoting"/>

                                </channel-creation-options>

                              </remote>

                              <thread-pools>

                                <thread-pool name="default">

                                  <max-threads count="10"/>

                                  <keepalive-time time="100" unit="milliseconds"/>

                                </thread-pool>

                              </thread-pools>

                              <iiop enable-by-default="false" use-qualified-name="false"/>

                              <default-security-domain value="other"/>

                              <default-missing-method-permissions-deny-access value="true"/>

                              <log-system-exceptions value="true"/>

                            </subsystem>

                            <subsystem xmlns="urn:wildfly:elytron:4.0" final-providers="combined-providers" disallowed-providers="OracleUcrypto">

                              <providers>

                                <aggregate-providers name="combined-providers">

                                  <providers name="elytron"/>

                                  <providers name="openssl"/>

                                </aggregate-providers>

                                <provider-loader name="elytron" module="org.wildfly.security.elytron"/>

                                <provider-loader name="openssl" module="org.wildfly.openssl"/>

                              </providers>

                              <audit-logging>

                                <file-audit-log name="local-audit" path="audit.log" relative-to="jboss.server.log.dir" format="JSON"/>

                              </audit-logging>

                              <security-domains>

                                <security-domain name="ApplicationDomain" default-realm="ApplicationRealm" permission-mapper="default-permission-mapper">

                                  <realm name="ApplicationRealm" role-decoder="groups-to-roles"/>

                                  <realm name="local"/>

                                </security-domain>

                                <security-domain name="ManagementDomain" default-realm="ManagementRealm" permission-mapper="default-permission-mapper">

                                  <realm name="ManagementRealm" role-decoder="groups-to-roles"/>

                                  <realm name="local" role-mapper="super-user-mapper"/>

                                </security-domain>

                              </security-domains>

                              <security-realms>

                                <identity-realm name="local" identity="$local"/>

                                <properties-realm name="ApplicationRealm">

                                  <users-properties path="application-users.properties" relative-to="jboss.server.config.dir" digest-realm-name="ApplicationRealm"/>

                                  <groups-properties path="application-roles.properties" relative-to="jboss.server.config.dir"/>

                                </properties-realm>

                                <properties-realm name="ManagementRealm">

                                  <users-properties path="mgmt-users.properties" relative-to="jboss.server.config.dir" digest-realm-name="ManagementRealm"/>

                                  <groups-properties path="mgmt-groups.properties" relative-to="jboss.server.config.dir"/>

                                </properties-realm>

                              </security-realms>

                              <mappers>

                                <simple-permission-mapper name="default-permission-mapper" mapping-mode="first">

                                  <permission-mapping>

                                    <principal name="anonymous"/>

                                    <permission-set name="default-permissions"/>

                                  </permission-mapping>

                                  <permission-mapping match-all="true">

                                    <permission-set name="login-permission"/>

                                    <permission-set name="default-permissions"/>

                                  </permission-mapping>

                                </simple-permission-mapper>

                                <constant-realm-mapper name="local" realm-name="local"/>

                                <simple-role-decoder name="groups-to-roles" attribute="groups"/>

                                <constant-role-mapper name="super-user-mapper">

                                  <role name="SuperUser"/>

                                </constant-role-mapper>

                              </mappers>

                              <permission-sets>

                                <permission-set name="login-permission">

                                  <permission class-name="org.wildfly.security.auth.permission.LoginPermission"/>

                                </permission-set>

                                <permission-set name="default-permissions">

                                  <permission class-name="org.wildfly.extension.batch.jberet.deployment.BatchPermission" module="org.wildfly.extension.batch.jberet" target-name="*"/>

                                  <permission class-name="org.wildfly.transaction.client.RemoteTransactionPermission" module="org.wildfly.transaction.client"/>

                                  <permission class-name="org.jboss.ejb.client.RemoteEJBPermission" module="org.jboss.ejb-client"/>

                                </permission-set>

                              </permission-sets>

                              <http>

                                <http-authentication-factory name="management-http-authentication" security-domain="ManagementDomain" http-server-mechanism-factory="global">

                                  <mechanism-configuration>

                                    <mechanism mechanism-name="DIGEST">

                                      <mechanism-realm realm-name="ManagementRealm"/>

                                    </mechanism>

                                  </mechanism-configuration>

                                </http-authentication-factory>

                                <provider-http-server-mechanism-factory name="global"/>

                              </http>

                              <sasl>

                                <sasl-authentication-factory name="application-sasl-authentication" sasl-server-factory="configured" security-domain="ApplicationDomain">

                                  <mechanism-configuration>

                                    <mechanism mechanism-name="JBOSS-LOCAL-USER" realm-mapper="local"/>

                                    <mechanism mechanism-name="DIGEST-MD5">

                                      <mechanism-realm realm-name="ApplicationRealm"/>

                                    </mechanism>

                                  </mechanism-configuration>

                                </sasl-authentication-factory>

                                <sasl-authentication-factory name="management-sasl-authentication" sasl-server-factory="configured" security-domain="ManagementDomain">

                                  <mechanism-configuration>

                                    <mechanism mechanism-name="JBOSS-LOCAL-USER" realm-mapper="local"/>

                                    <mechanism mechanism-name="DIGEST-MD5">

                                      <mechanism-realm realm-name="ManagementRealm"/>

                                    </mechanism>

                                  </mechanism-configuration>

                                </sasl-authentication-factory>

                                <configurable-sasl-server-factory name="configured" sasl-server-factory="elytron">

                                  <properties>

                                    <property name="wildfly.sasl.local-user.default-user" value="$local"/>

                                  </properties>

                                </configurable-sasl-server-factory>

                                <mechanism-provider-filtering-sasl-server-factory name="elytron" sasl-server-factory="global">

                                  <filters>

                                    <filter provider-name="WildFlyElytron"/>

                                  </filters>

                                </mechanism-provider-filtering-sasl-server-factory>

                                <provider-sasl-server-factory name="global"/>

                              </sasl>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:iiop-openjdk:2.1">

                              <initializers security="identity" transactions="spec"/>

                              <security server-requires-ssl="false" client-requires-ssl="false"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:infinispan:7.0">

                              <cache-container name="server" default-cache="default" module="org.wildfly.clustering.server">

                                <local-cache name="default">

                                  <transaction mode="BATCH"/>

                                </local-cache>

                              </cache-container>

                              <cache-container name="web" default-cache="passivation" module="org.wildfly.clustering.web.infinispan">

                                <local-cache name="passivation">

                                  <locking isolation="REPEATABLE_READ"/>

                                  <transaction mode="BATCH"/>

                                  <file-store passivation="true" purge="false"/>

                                </local-cache>

                              </cache-container>

                              <cache-container name="ejb" aliases="sfsb" default-cache="passivation" module="org.wildfly.clustering.ejb.infinispan">

                                <local-cache name="passivation">

                                  <locking isolation="REPEATABLE_READ"/>

                                  <transaction mode="BATCH"/>

                                  <file-store passivation="true" purge="false"/>

                                </local-cache>

                              </cache-container>

                              <cache-container name="hibernate" module="org.infinispan.hibernate-cache">

                                <local-cache name="entity">

                                  <transaction mode="NON_XA"/>

                                  <object-memory size="10000"/>

                                  <expiration max-idle="100000"/>

                                </local-cache>

                                <local-cache name="local-query">

                                  <object-memory size="10000"/>

                                  <expiration max-idle="100000"/>

                                </local-cache>

                                <local-cache name="timestamps"/>

                              </cache-container>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:io:3.0">

                              <worker name="default"/>

                              <buffer-pool name="default"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:jca:5.0">

                              <archive-validation enabled="true" fail-on-error="true" fail-on-warn="false"/>

                              <bean-validation enabled="true"/>

                              <default-workmanager>

                                <short-running-threads>

                                  <core-threads count="50"/>

                                  <queue-length count="50"/>

                                  <max-threads count="50"/>

                                  <keepalive-time time="10" unit="seconds"/>

                                </short-running-threads>

                                <long-running-threads>

                                  <core-threads count="50"/>

                                  <queue-length count="50"/>

                                  <max-threads count="50"/>

                                  <keepalive-time time="10" unit="seconds"/>

                                </long-running-threads>

                              </default-workmanager>

                              <cached-connection-manager/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:jdr:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:jmx:1.3">

                              <expose-resolved-model/>

                              <expose-expression-model/>

                              <remoting-connector/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:jpa:1.1">

                              <jpa default-datasource="" default-extended-persistence-inheritance="DEEP"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:jsf:1.1"/>

                            <subsystem xmlns="urn:jboss:domain:jsr77:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:mail:3.0">

                              <mail-session name="default" jndi-name="java:jboss/mail/Default">

                                <smtp-server outbound-socket-binding-ref="mail-smtp"/>

                              </mail-session>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:messaging-activemq:4.0">

                              <server name="default" persistence-enabled="true">

                                <journal type="NIO" min-files="2"/>

                                <remote-connector name="netty" socket-binding="messaging"/>

                                        <param name="ssl-enabled" value="true"/>

                                        <param name="key-store-path" value="/java/jre/lib/security/appkeystore.jks"/>

                                        <param name="key-store-password" value="****"/>

                        <param name="trust-store-path" value="/java/jre/lib/security/truststore.jks"/>

                        <param name="trust-store-password" value="**"/>

                                </remote-connector>

                                <remote-connector name="netty-throughput" socket-binding="messaging-throughput">

                                       <param name="ssl-enabled" value="true"/>

                                       <param name="key-store-path" value="//java/jre/lib/security/appkeystore.jks"/>

                                       <param name="key-store-password" value="*****"/>

                           <param name="trust-store-path" value="/java/jre/lib/security/truststore.jks"/>

                        <param name="trust-store-password" value="**"/>

                        </remote-connector>

                         

                         

                                <in-vm-connector name="in-vm" server-id="0"/>

                                <connector name="remote-activemq-nonmanaged" socket-binding="activemq-messaging" factory-class="org.apache.activemq.artemis.core.remoting.impl.netty.NettyConnectorFactory"/>

                                <remote-acceptor name="netty" socket-binding="messaging"/>

                                <remote-acceptor name="netty-throughput" socket-binding="messaging-throughput">

                                  <param name="batch-delay" value="50"/>

                                </remote-acceptor>

                                <in-vm-acceptor name="in-vm" server-id="0"/>

                                <security-setting name="#">

                                  <role name="admin" send="true" consume="true" create-durable-queue="true" delete-durable-queue="true" create-non-durable-queue="true" delete-non-durable-queue="true" manage="true"/>

                                  <role name="guest" send="true" consume="true" create-durable-queue="true" delete-durable-queue="true" create-non-durable-queue="true" delete-non-durable-queue="true" manage="true"/>

                                </security-setting>

                                <address-setting name="#" dead-letter-address="jms.queue.DLQ" expiry-address="jms.queue.ExpiryQueue" redelivery-delay="0" max-size-bytes="1048576" page-size-bytes="2097152" address-full-policy="PAGE" message-counter-history-day-limit="10" last-value-queue="true"/>

                                <connection-factory name="InVmConnectionFactory" entries="java:/ConnectionFactory" connectors="in-vm"/>

                                <connection-factory name="RemoteConnectionFactory" entries="java:jboss/exported/jms/RemoteConnectionFactory" connectors="netty"/>

                                <pooled-connection-factory name="activemq-ra" entries="java:/JmsXA java:jboss/DefaultJMSConnectionFactory" connectors="in-vm" transaction="xa"/>

                        <jms-queue name="remoteQueue" entries="java:jboss/exported/jms/queue/remoteQueue"/>

                         

                           </server>

                            <subsystem xmlns="urn:wildfly:microprofile-config-smallrye:1.0"/>

                            <subsystem xmlns="urn:wildfly:microprofile-health-smallrye:1.0" security-enabled="false"/>

                            <subsystem xmlns="urn:wildfly:microprofile-opentracing-smallrye:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:naming:2.0"/>

                                 <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:remoting:4.0">

                              <connector name="remoting-connector" socket-binding="remoting" security-realm="ApplicationRealm"/>

                              <http-connector name="http-remoting-connector" connector-ref="default" security-realm="ApplicationRealm"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:request-controller:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:resource-adapters:5.0"/>

                            <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

                            <subsystem xmlns="urn:jboss:domain:security:2.0">

                              <security-domains>

                                <security-domain name="other" cache-type="default">

                                  <authentication>

                                    <login-module code="Remoting" flag="optional">

                                      <module-option name="password-stacking" value="useFirstPass"/>

                                    </login-module>

                                    <login-module code="RealmDirect" flag="required">

                                      <module-option name="password-stacking" value="useFirstPass"/>

                                    </login-module>

                                  </authentication>

                                </security-domain>

                                <security-domain name="jboss-web-policy" cache-type="default">

                                  <authorization>

                                    <policy-module code="Delegating" flag="required"/>

                                  </authorization>

                                </security-domain>

                                <security-domain name="jaspitest" cache-type="default">

                                  <authentication-jaspi>

                                    <login-module-stack name="dummy">

                                      <login-module code="Dummy" flag="optional"/>

                                    </login-module-stack>

                                    <auth-module code="Dummy"/>

                                  </authentication-jaspi>

                                </security-domain>

                                <security-domain name="jboss-ejb-policy" cache-type="default">

                                  <authorization>

                                    <policy-module code="Delegating" flag="required"/>

                                  </authorization>

                                </security-domain>

                              </security-domains>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:security-manager:1.0">

                              <deployment-permissions>

                                <maximum-set>

                                  <permission class="java.security.AllPermission"/>

                                </maximum-set>

                              </deployment-permissions>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:transactions:5.0">

                              <core-environment>

                                <process-id>

                                  <uuid/>

                                </process-id>

                              </core-environment>

                              <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                              <coordinator-environment default-timeout="3600"/>

                              <object-store relative-to="jboss.server.data.dir"/>

                              <use-journal-store/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:undertow:7.0" default-virtual-host="default-host">

                              <buffer-cache name="default"/>

                              <server name="default-server" default-host="default-host">

                                <http-listener name="default" socket-binding="http" redirect-socket="https" max-parameters="10000"/>

                                <https-listener name="https" socket-binding="https" security-realm="UndertowRealm" enabled-protocols="TLSv1"/>

                                <host name="default-host" alias="localhost,example.com">

                                  <location name="/" handler="welcome-content"/>

                                  <http-invoker security-realm="ApplicationRealm"/>

                                </host>

                              </server>

                              <servlet-container name="default">

                                <jsp-config x-powered-by="false" display-source-fragment="false"/>

                                <websockets/>

                              </servlet-container>

                              <handlers>

                                <file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>

                              </handlers>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:webservices:2.0">

                              <modify-wsdl-address>true</modify-wsdl-address>

                              <wsdl-host>127.0.0.1</wsdl-host>

                              <endpoint-config name="Standard-Endpoint-Config"/>

                              <endpoint-config name="Recording-Endpoint-Config">

                                <pre-handler-chain name="recording-handlers" protocol-bindings="##SOAP11_HTTP ##SOAP11_HTTP_MTOM ##SOAP12_HTTP ##SOAP12_HTTP_MTOM">

                                  <handler name="RecordingHandler" class="org.jboss.ws.common.invocation.RecordingServerHandler"/>

                                </pre-handler-chain>

                              </endpoint-config>

                              <client-config name="Standard-Client-Config"/>

                            </subsystem>

                            <subsystem xmlns="urn:jboss:domain:weld:4.0"/>

                          </profile>

                          <interfaces>

                            <interface name="management">

                              <inet-address value="127.0.0.1"/>

                            </interface>

                            <interface name="public">

                              <inet-address value="127.0.0.1"/>

                            </interface>

                            <interface name="unsecure">

                              <inet-address value="127.0.0.1"/>

                            </interface>

                          </interfaces>

                          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

                            <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

                            <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

                            <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>

                            <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/>

                            <socket-binding name="http" port="${jboss.http.port:8080}"/>

                            <socket-binding name="https" port="${jboss.https.port:8443}"/>

                            <socket-binding name="txn-recovery-environment" port="4712"/>

                            <socket-binding name="txn-status-manager" port="4713"/>

                            <socket-binding name="remoting" port="4447"/>

                            <socket-binding name="messaging" port="5445"/>

                            <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>

                            <socket-binding name="messaging-throughput" port="5455"/>

                            <socket-binding name="activemq-messaging" port="5456"/>

                            <socket-binding name="jndi" port="1099"/>

                            <outbound-socket-binding name="mail-smtp">

                              <remote-destination host="localhost" port="25"/>

                            </outbound-socket-binding>

                          </socket-binding-group>

                        </server>

                         

                        Error Dteail:

                        Caused by: javax.net.ssl.SSLHandshakeException: General SSLEngine problem

                                at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)

                                at sun.security.ssl.SSLEngineImpl.fatal(SSLEngineImpl.java:1709)

                                at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:318)

                                at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:310)

                                at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1639)

                                at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:223)

                                at sun.security.ssl.Handshaker.processLoop(Handshaker.java:1037)

                                at sun.security.ssl.Handshaker$1.run(Handshaker.java:970)

                                at sun.security.ssl.Handshaker$1.run(Handshaker.java:967)

                                at java.security.AccessController.doPrivileged(Native Method)

                                at sun.security.ssl.Handshaker$DelegatedTask.run(Handshaker.java:1459)

                                at org.xnio.ssl.JsseSslConduitEngine.handleHandshake(JsseSslConduitEngine.java:543)

                                at org.xnio.ssl.JsseSslConduitEngine.wrap(JsseSslConduitEngine.java:245)

                                at org.xnio.ssl.JsseSslStreamSinkConduit.write(JsseSslStreamSinkConduit.java:113)

                                at org.xnio.ssl.JsseSslStreamSinkConduit.write(JsseSslStreamSinkConduit.java:77)

                                at org.xnio.conduits.ConduitStreamSinkChannel.write(ConduitStreamSinkChannel.java:154)

                                at org.jboss.remoting3.remote.RemoteConnection$RemoteWriteListener.handleEvent(RemoteConnection.java:262)

                                at org.jboss.remoting3.remote.RemoteConnection$RemoteWriteListener.handleEvent(RemoteConnection.java:243)

                                at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:92)

                                at org.xnio.conduits.WriteReadyHandler$ChannelListenerHandler.writeReady(WriteReadyHandler.java:65)

                                at org.xnio.nio.NioSocketConduit.handleReady(NioSocketConduit.java:94)

                                at org.xnio.nio.WorkerThread.run(WorkerThread.java:591)

                        Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

                                at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:397)