1 Reply Latest reply on Apr 1, 2002 9:07 PM by Peter Kelley

    ejb lookup problem in jboss 2.4.4 with embedded tomcat 4.01

    Cornel Newbie

      I use JBoss 2.4.4 with embedded Tomcat 4.01 and I deployed an .ear that contains an ejb an a .war. When it's performed the lookup is thrown the following exception:

      [15:46:28,991,Default] java.io.InvalidClassException: java.lang.ObjectMissing no-arg constructor for class
      [15:46:29,011,Default] at java.io.ObjectInputStream.inputObject(Unknown Source)
      [15:46:29,031,Default]
      [15:46:29,041,Default] at java.io.ObjectInputStream.readObject(Unknown Source)
      [15:46:29,051,Default]
      [15:46:29,071,Default] at java.io.ObjectInputStream.readObject(Unknown Source)
      [15:46:29,081,Default]
      [15:46:29,091,Default] at java.rmi.MarshalledObject.get(Unknown Source)
      [15:46:29,101,Default]
      [15:46:29,111,Default] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:454)
      [15:46:29,131,Default]
      [15:46:29,141,Default] at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:422)
      [15:46:29,161,Default]
      [15:46:29,171,Default] at javax.naming.InitialContext.lookup(Unknown Source)
      [15:46:29,181,Default]
      [15:46:29,191,Default] at com.caatoosee.flwrapper.web.WebConfig.createConnection(WebConfig.java:403)
      [15:46:29,212,Default]
      [15:46:29,222,Default] at com.caatoosee.flwrapper.web.WebConfig.login(WebConfig.java:499)
      [15:46:29,252,Default]
      [15:46:29,262,Default] at org.apache.jsp._0002flogin_jsp._jspService(_0002flogin_jsp.java:164)
      .....
      [ERROR,Default] javax.naming.CommunicationException. Root exception is
      [ERROR,Default] java.io.IOException: java.lang.ObjectMissing no-arg constructor
      for class
      [ERROR,Default] at org.jnp.interfaces.NamingContext.lookup(NamingContext
      .java:457)
      [ERROR,Default]
      [ERROR,Default] at org.jnp.interfaces.NamingContext.lookup(NamingContext
      .java:422)
      [ERROR,Default]
      [ERROR,Default] at javax.naming.InitialContext.lookup(Unknown Source)
      [ERROR,Default]
      [ERROR,Default] at com.caatoosee.flwrapper.web.WebConfig.createConnectio
      n(WebConfig.java:403)
      [ERROR,Default]
      [ERROR,Default] at com.caatoosee.flwrapper.web.WebConfig.login(WebConfig
      .java:499)
      [ERROR,Default]
      [ERROR,Default] at org.apache.jsp._0002flogin_jsp._jspService(_0002flogi
      n_jsp.java:164)

      The bean has a no-arguments constructor.
      If I use JBoss 2.4.4 with standalone Tomcat 4.01 the lookup it's working.
      Can anybody help me?

      Cornel