2 Replies Latest reply on Apr 16, 2002 11:28 AM by Keith Davey

    Deploying ear file

    Keith Davey Newbie

      I am migrating my application from 2.4.5 to version 3.0 beta. I have made all the modifications for the configuration files and got all my code up to the EJB 2.0 standard. But now when I deply the ear file to the \deploy directory and start up JBoss, I get the following sequence of message as it trys to deploy my ear file. It says that it has started to deploy it, but nothing gets deployed and I have about 50 beans in the ear file. Sometimes when I recompile and do a hot deploy it will pick it up and try to deploy the beans. Any help would be great.

      I am running on Win 2K.

      kmd

      16:55:28,953 INFO [EJBDeployer] Deploying MEJB
      16:55:28,984 INFO [MainDeployer] Deploying: file:/C:/jboss/deploy/genotyping.ear
      16:55:29,000 INFO [EARDeployer] Init J2EE application: file:/C:/jboss/deploy/genotyping.ear
      16:55:29,046 INFO [EARDeployer] Deploying J2EE application: file:/C:/jboss/deploy/genotyping.ear
      16:55:29,093 INFO [MainDeployer] Deploying: file:/C:/jboss/deploy/jbossmq-state.xml
      16:55:29,156 INFO [MainDeployer] Started
      16:55:29,156 INFO [Server] JBoss (MX MicroKernel) [3.0.0beta Date:200202210220] Started in 0m:24s:94ms

        • 1. Re: Deploying ear file
          Keith Davey Newbie

          I have a further question on this. I am still not having any luck with this file. Worked fine in 2.4.5 and not here. It says that it deploys, but when I go look on line through the JNDIView I am not seeing anything. When I run the app, I can not see the beans. I have attached the application.xmp, jboss.xml, ejb-jar.xml and the jbosscmp-jdbc.xml.

          • 2. Re: Deploying ear file
            Keith Davey Newbie

            One more thing that I have found. When I deploy the ear file to the alpha version, I get error messages from it trying to deploy the ear file. Which is what I would expect. So the big question on my mine, is what the heck am I missing from the alpha version to the latest beta version? I really need to fix this in the next day or so or I am going to have to move back to 2.4.5 and start coding a solution for that.

            thanks

            kmd