0 Replies Latest reply on Oct 22, 2002 10:27 AM by randy

    Jbuilder 7 Debug Error "Cannot find StatelessSessionContaine

    randy Newbie

      Hi,
      I'm running jb7EE, latest patches on Redhat 8.0. I have a very simple CMP EJB 2.0 called Ship, and a stateless session bean called TravelAgen, with getShip and a setShip. The take/return a value object called ShipVO. I have a native client that tries to get an existing ship by calling the session bean with an integer id, and expects to get a ShipVO. I have a breakpoint set in the getShip() method of the travel agent. When I get to the following line

      ShipHomeLocal shipHome = (ShipHomeLocal)jndiContext.lookup("ShipHomeLocal");

      in the getShip() method, it dies with a "Cannot find StatelessSessionContainer.java. It also shows "Stopped at line 667, in method invoke(), class org.jboss.ejb.StatelessSessionContainer$ContainerInterceptor in the debug message bar.

      I have this same problem with Jboss_3.0.3, Jboss_3.0.3_Tomcat_4.0.5 and jboss_3.0.3_Tomcat_4.1.12.

      FWIW, I also get this same error with the protegra Enterprise Jbuilder plugin thingy.

      I get the same error if I try to create a ship (by calling the addShip(ShipVO) on the session bean. The interesting thing is that it dies on the jndi lookup also. with the same error messages, and LOC.

      ShipHomeLocal shipHome = (ShipHomeLocal)jndiContext.lookup("ShipHomeLocal");

      My first thought would be that this is a jndi lookup problem, but wouldn't that throw an exception rather than just die?