5 Replies Latest reply on Jan 30, 2003 12:02 PM by Elmar Henne

    Intersts in petstore 1.3.1 on JBoss 3.2?

    Bernd Koecke Novice

      Hi,

      we adopted petstore 1.3.1 for JBoss 3.2RC1. Are there interests in a tarball of this? Our environment and features are:
      - Linux
      - Sun JDK 1.4.1/1.3.1_06
      - JBoss 3.2 RC1
      - Eclipse 2.0.2 IDE
      - Use of autogenerated unknown primary keys
      - PostgreSQL 7.2 with sequences for the PK generation
      - Class generation with eclipse, the ear files are build with ant

      You could go to the petstore webfrontend, browse the pets, generate an account and place your order. Than you could manage the orders with the adminclient with Java Webstart.

      The webservices are not adopted and tested and in our cvs checkout of JBoss seems to be a problem with the deployed packages. If you restart JBoss with deployed petstore ear files you get an exception when you send and order. We don't know yet if it is a bug in JBoss or in our petstore packages.

      If there are interestes, how should we send it? The tar.gz file is about 8MB.

      Bernd and Markus