2 Replies Latest reply on May 1, 2003 12:24 PM by logangilbert

    Problems deploying/debugging

    logangilbert Newbie

      Hello all,

      I am having an issue when re-deploying a jar with EJB's to JBoss. My example may make more sense:

      Run JBoss in debug mode
      Compile, jar, and deploy jarfile
      In IntelliJ, hook up to JBoss via remote debugging
      Run my test.

      At this point the test runs, make the EJBs and I can set breakpoints within them and debug them just fine.

      Next, I make some code changes, recompile, build a jar, and copy the jar to the deploy area, and Jboss correctly picks up the new jarfile. However, when I debug again, it's obvious that I'm stepping over the old code.

      It's as though JBoss has the bean in memory and even though a new jar is deployed, JBoss is completely content with the one it has. :)

      Basically my only solution so far is that everytime I modify code, I have to restart JBoss.

      This is the message from JBoss when I deploy my re-compiled/re-deployed jarfile:

      18:12:11,201 INFO [MainDeployer] Undeploying
      file:/C:/jboss-3.0.4-tomcat-4.0.6/server/ourservice/deploy/myjar.jar

      18:12:11,201 INFO [MainDeployer] could not delete directory file:/C:/jboss-3.0.4-tomcat-4.0.6/server/ourservice/tmp/deploy/server/ourservice/deploy/myjar.jar/102.myjar.jar restart will delete it

      18:12:11,201 INFO [MainDeployer] Undeployed
      file:/C:/jboss-3.0.4-tomcat-4.0.6/server/ourservice/deploy/myjar.jar

      18:12:11,201 INFO [MainDeployer] Starting deployment of package:
      file:/C:/jboss-3.0.4-tomcat-4.0.6/server/ourservice/deploy/myjar.jar

      18:12:11,264 INFO [MainDeployer] Deployed package:
      file:/C:/jboss-3.0.4-tomcat-4.0.6/server/ourservice/deploy/myjar.jar

      Any thoughts greatly appreciated
      Logan