3 Replies Latest reply on Jul 25, 2003 7:48 PM by zapa

    Problem deploying my first EJB

    zapa Newbie

      Hi there ,

      I have been trying to deploy my first EJB for about 2 days now . Initially i've started with the workbooks from o'reilly then after understanding the stuff in there I've moved to a very similar thing , yet a bean built by me , from scratch .

      I ran into the same problem with this bean , that I initially had run into while using the workbook examples :

      javax.naming.NameNotFoundException: AuthHomeRemote not bound

      here is what the jar contains :
      org/example/auth/ :
      AuthBean.class , AuthHomeRemote.class , AuthRemote.class , META-INF

      org/example/auth/META-INF :
      MANIFEST.MF , ejb-jar.xml , jboss.xml

      jboss.xml :


      <enterprise-beans>

      <ejb-name>AuthEJB</ejb-name>
      <jndi-name>AuthHomeRemote</jndi-name>

      </enterprise-beans>



      On the console I get LOTS of output ... so much that i can't really scrool up and see everything that was outputted . here are a few of the "FAILURES" i could see :

      Incompletely deployed packages:
      [org.jboss.deployment.DeploymentInfo@780f58a3 { url=file:/usr/local/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/management/ejb-management.jar }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/usr/local/jboss-3.2.1_tomcat-4.1.24/server/default/deploy/management/ejb-management.jar
      ---
      [ObjectName: jboss:service=WebService
      state: FAILED
      I Depend On:
      Depends On Me: jboss.ejb:service=EJBDeployer
      java.lang.NullPointerException, ObjectName: jboss.ejb:service=EJBDeployer
      state: CONFIGURED
      ---
      Depends On Me: , ObjectName: jboss:service=invoker,type=jrmp
      state: FAILED
      I Depend On: jboss:service=TransactionManager

      Depends On Me: jboss.jmx:type=adaptor,name=Invoker,protocol=jrmp,service=proxyFactory
      java.net.UnknownHostException: dune: dune, ObjectName: jboss:service=invoker,type=pooled
      state: FAILED
      I Depend On: jboss:service=TransactionManager

      Depends On Me: java.net.UnknownHostException: dune: dune, ObjectName: jboss:service=invoker,type=http
      state: FAILED
      --- etc ...

      Any help would really be apreciated ..

        • 1. Re: Problem deploying my first EJB
          tiltedj Newbie

          which server are you running? if its minimal you wont be able to deploy your EJB. if so try switching to default server.

          kevin

          • 2. Re: Problem deploying my first EJB
            zapa Newbie

            I was running default config for Jboss 3.2.1

            • 3. Re: Problem deploying my first EJB
              zapa Newbie

              damn ...

              well ... here is the story . It seems that my code was just right all along . I deployed the same jar in a windows 2000 enviroement with the same JBoss 3.2.1 and it worked just great .

              The old system I was using was Gentoo Linux , and I suspect there might be a bug in there somewhere ...

              If anybody is interested in any specific details and log files , just ask a few specific questions and I will do my best to cooperate and help . I'd dig a bit myself , but i'm a noob so i'd rather dig in my EJB book for the time beeing :)

              thanks to anybody that wasted their time reading about my problems ;)