1 Reply Latest reply on Jan 29, 2004 5:19 AM by Darran Lofthouse

    Problems with deploying Converter.jar

    espenra Newbie

       

      "espenra" wrote:
      I have compiled the converter source files taken from the J2EE 1.4 tutorial. 4 files: Converter, ConverterClient, ConverterBean and ConverterHome.java.

      I compiled using the javac command including some j2ee library from jboss.

      My problem is the xml files:
      I got two files:

      ejb-jar.xml and jboss.xml
      ejb-jar.xml:
      <!DOCTYPE ejb-jar PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN" "http://java.sun.com/dtd/ejb-jar_2_0.dtd">
      <ejb-jar>
      <enterprise-beans>
      <session>
      <ejb-name>Converter</ejb-name>
      < home> ConverterHome</home >
      < remote> Converter</remote >
      <ejb-class>ConverterBean</ejb-class>
      <session-type>Stateless</session-type>
      <transaction-type>Container</transaction-type>
      </session>
      </enterprise-beans>
      </ejb-jar>


      jboss.xml:
      <jboss>
      <enterprise-beans>
      <session>
      <ejb-name>Converter</ejb-name>
      <ejb-ref>
      <ejb-ref-name>Converter</ejb-ref-name>
      <jndi-name>Converter</jndi-name>
      </ejb-ref>
      </session>
      <enterprise-beans>
      </jboss>


      After putting the compiled files and xml files into a jar file, and deploying it under /server/default/deploy in jboss, I got an error like this:

      Cause: Incomplete Deployment listing:
      Packages waiting for a deployer:
      <none>
      Incompletely deployed packages:
      [org.jboss.deployment.DeploymentInfo@eb89fd7a { url=file:/H:/Jboss-3.2.3/jboss-3
      .2.3/server/default/deploy/Converter.jar }
      deployer: org.jboss.ejb.EJBDeployer@2db19d
      status: null
      state: FAILED
      watch: file:/H:/Jboss-3.2.3/jboss-3.2.3/server/default/deploy/Converter.jar
      lastDeployed: 1075360750210
      lastModified: 1075360749000
      mbeans:
      ]MBeans waiting for classes:
      <none>
      MBeans waiting for other MBeans:
      <none>

      08:19:31,959 INFO [URLDeploymentScanner] Started jboss.deployment:type=Deployme
      ntScanner,flavor=URL
      08:19:32,053 INFO [MainDeployer] Deployed package: file:/H:/Jboss-3.2.3/jboss-3
      .2.3/server/default/conf/jboss-service.xml
      08:19:32,069 INFO [Server] JBoss (MX MicroKernel) [3.2.3 (build: CVSTag=JBoss_3
      _2_3 date=200311301445)] Started in 1m:51s:671ms


      Any ideas what's wrong?

      Begging for help!