3 Replies Latest reply on Apr 14, 2004 8:05 AM by Joachim Van der Auwera

    Problems with Jboss CMP

    vla Newbie

      I have an application (EJB) that was designed for j2ee 1.3 and now I want to move it on Jboss. The major problem is that JBoss doe not use quotes to souround table and colum names. Some of my tables have names that are reserved for mysql (the target data base) and somewone showed me how to bipass this step (adding the needed words in jboss reserved words, but this is only avalible for tables). The prolem I encountered now is at an relation table (relates two tabls), witch has as colum names two reserved words. Is there any way I can avoid the use of these reserved words with Jboss? (of coure Jboss charashes from mysql)

        • 1. Re: Problems with Jboss CMP
          Joachim Van der Auwera Expert

          "fixing" fieldnames is not possible at this moment.
          The best solution is to use a prefix (like "F_") or suffix for all your fields.

          Or you could write and submit a patch to make this automatic (when configured as such).

          Joachim

          • 2. Re: Problems with Jboss CMP
            vla Newbie

            thanks again, but I didn`t quite undestood what you says, did you meant that I have to edit the source code and modify the column names (and probably the table names) and then rebuild the application? (will it work in ths case, if the application is built with forte4 for j2ee 1.3?)

            • 3. Re: Problems with Jboss CMP
              Joachim Van der Auwera Expert

              You have two options :

              1. edit the descriptors for you application and change the column names there.

              2. produce a JBoss patch to make sure a prefix can be added to the fieldnames.

              THe first option in by far the easiest, but the second would benefit many people whc have similar problems.

              Joachim