1 Reply Latest reply on Feb 9, 2005 9:16 PM by caesarkim

    add new field to CMP to create a new column

    caesarkim Newbie

      I added a new field to one of my CMPs to create a new column. I am using Jboss 3.2.5 and Mysql 4. This is my jbosscmp-jdbc.xml

      java:/jdbc/MySQLDS
      <datasource-mapping>mySQL</datasource-mapping>
      <create-table>true</create-table>
      <alter-table>true</alter-table>
      <remove-table>false</remove-table>

      even though i redeploy EAR file, it doesn't update a table. is there anything else that I have to look into?

      Thanks..


        • 1. Re: add new field to CMP to create a new column
          caesarkim Newbie

           

          "caesarkim" wrote:
          I added a new field to one of my CMPs to create a new column. I am using Jboss 3.2.5 and Mysql 4. This is my jbosscmp-jdbc.xml
          <defaults>
          <datasource>java:/jdbc/MySQLDS</datasource>
          <datasource-mapping>mySQL</datasource-mapping>
          <create-table>true</create-table>
          <alter-table>true</alter-table>
          <remove-table>false</remove-table>

          There are some data in it. I don't want to delete it. The following is the columns.

          <cmp-field><field-name>id</field-name></cmp-field>
          <cmp-field><field-name>developerId</field-name></cmp-field>
          <cmp-field><field-name>subProjectId</field-name></cmp-field>
          <cmp-field><field-name>readMode</field-name></cmp-field>
          <cmp-field><field-name>editMode</field-name></cmp-field>
          <cmp-field><field-name>removeMode</field-name></cmp-field>
          <cmp-field><field-name>exportMode</field-name></cmp-field>
          <cmp-field><field-name>writeMode</field-name></cmp-field>
          <cmp-field><field-name>uploadMode</field-name></cmp-field>
          <cmp-field><field-name>createDate</field-name></cmp-field>
          <cmp-field><field-name>lastChange</field-name></cmp-field>


          uploadMode is the new column. even though i redeploy EAR file, it doesn't update a table. is there anything else that I have to look into?





          Thanks..