1 Reply Latest reply on Apr 7, 2005 11:24 AM by Brian

    jdom problems with 4.0.1sp1

    Brian Newbie

      I have recently upgraded from jboss 4.0.0 to jboss 4.0.1sp1. However my ejb jar file that ran fine under 4.0.0 is failing under 4.0.1sp1. I have tracked the problem down to the jdom.jar inside my ejb jar file. For some reason jboss takes exception to it. I get the error:

      2005-04-04 16:19:59,410 ERROR [org.jboss.deployment.scanner.URLDeploymentScanner] Incomplete Deployment listing:
      Packages waiting for a deployer:
      org.jboss.deployment.DeploymentInfo@5256316d { url=file:/export/home/fowlerb/jboss-4.0.1sp1/server/tms/tmp/deploy/tmp19781tms.jar-contents/jdom.jar }
      deployer: null
      status: null
      state: CREATE_SUBDEPLOYMENTS
      watch: file:/export/home/fowlerb/jboss-4.0.1sp1/server/tms/tmp/deploy/tmp19781tms.jar-contents/jdom.jar
      altDD: null
      lastDeployed: 1112631598837
      lastModified: 1112631598000
      mbeans:

      Any ideas why jboss 4.0.1sp1 is objecting to jdom? (and why jboss 4.0.0 didn't)

      Cheers,

      Brian

        • 1. Re: jdom problems with 4.0.1sp1
          Brian Newbie

          Just in case anyone has a similar problem, tracked this issue down to the info.xml file inside the MANIFEST.MF in the jdom.jar. This seems to be causing JBoss to think it is something more than just a regular java archive. Anyway repackaging jdom without this file resolved the problem.

          Brian