3 Replies Latest reply on Apr 15, 2005 5:11 AM by micke

    Configuring dataSource For BMP EntityBeans

    Premlatha Sundararajan Newbie

      hi,
      i've deployed a BMP Entity Bean on JBoss4.0.1. i'm inserting a record in to a table. Unfortunately, i'm not able to do it in the Oracle Database(inspite of setting the DataSource). This done in the Defaul;t Database (Hypersonic.) I've followed the same settings (configurations), as for CMP Entity Beans, should i do something differently, or is there something i've missed?

      Thanks

        • 1. Re: Configuring dataSource For BMP EntityBeans
          micke Novice

          1. Define and deploy the Oracle DS (oracle-ds.xml).
          2. Grab a connection for the BMP bean from that DS using its jndi-name.

          • 2. Re: Configuring dataSource For BMP EntityBeans
            Premlatha Sundararajan Newbie

            hi,

            "milowe" wrote:
            1. Define and deploy the Oracle DS (oracle-ds.xml).
            2. Grab a connection for the BMP bean from that DS using its jndi-name.


            .........Deployed oracle DS, and also created the connection for BMP to that DS. But my database transaction is with a table on the default Database,'coz i don't see any modifications to the table in my oracle Database.
            well, my console shows this.

            09:58:56,875 INFO [WrapperDataSourceService] Bound connection factory for resou
            rce adapter for ConnectionManager 'jboss.jca:name=DefaultDS,service=DataSourceBi
            nding to JNDI name 'java:DefaultDS'
            09:58:56,906 WARN [ConfiguredIdentityLoginModule] Creating LoginModule with no
            configured password!

            and

            09:58:57,671 INFO [WrapperDataSourceService] Bound connection factory for resou
            rce adapter for ConnectionManager 'jboss.jca:name=OracleDS,service=DataSourceBin
            ding to JNDI name 'java:OracleDS'

            will this have something to do with my problem,( having both the DataSources simultaneoulsy).
            Thanks for any help provided


            • 3. Re: Configuring dataSource For BMP EntityBeans
              micke Novice

              There can be more than one DS deployed at the same time so thats not the problem. I suggest that you read the log files and check that the connection is created and good. Are you sure that you connect to Hypersonic DB or are you just assuming this? Check your OracleDS and make sure its connection-url and driver-class points to your Oracle server.