1 Reply Latest reply on Jul 13, 2005 7:24 AM by Sergey Vorov

    JBoss doesn't deploy my EJB

    Sergey Vorov Newbie

      Hi,

      Please give me advise. I have next problem:
      When JBoss is loading, it deploy my ab.ear, but JBoss doesn't deploy my ejb from that ear. In JBoss console there are not any WARNINGS or ERRORS messages.

      ab.ear/META-INF/application.xml is next:
      //------
      <!DOCTYPE application PUBLIC
      "-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN"
      "http://java.sun.com/dtd/application_1_3.dtd">


      <display-name>Enterprise Application</display-name>

      std_axiom_ejb.jar


      chap2-ex3.jar



      //------
      Note:
      chap2-ex3.jar - it is example ejb from book, JBoss deploy it perfectly.
      Problem with std_axiom_ejb.jar - JBoss ignore it -(

      If it will be usefull. JBoss log is next:
      //------
      17:36:09,026 INFO [MainDeployer] Starting deployment of package: file:/D:/landm
      ark/jboss-3.2.3/server/default/deploy/ab.ear
      17:36:41,593 INFO [EARDeployer] Init J2EE application: file:/D:/landmark/jboss-
      3.2.3/server/default/deploy/ab.ear
      17:37:13,068 INFO [EjbModule] Deploying Chap2EchoInfoBean
      17:37:14,530 INFO [EjbModule] Deploying chap2.EchoBean
      17:37:19,227 INFO [Chap2EchoInfoBean] Table 'CHAP2ECHOINFOBEAN' already exists
      17:37:19,277 INFO [EntityInstancePool] Started jboss.j2ee:jndiName=local/Chap2E
      choInfoBean,plugin=pool,service=EJB
      17:37:19,277 INFO [EntityContainer] Started jboss.j2ee:jndiName=local/Chap2Echo
      InfoBean,service=EJB
      17:37:19,327 INFO [StatelessSessionInstancePool] Started jboss.j2ee:jndiName=lo
      cal/chap2.EchoBean,plugin=pool,service=EJB
      17:37:19,327 INFO [StatelessSessionContainer] Started jboss.j2ee:jndiName=local
      /chap2.EchoBean,service=EJB
      17:37:19,327 INFO [EjbModule] Started jboss.j2ee:module=chap2-ex3.jar,service=E
      jbModule
      17:37:19,327 INFO [EJBDeployer] Deployed: file:/D:/landmark/jboss-3.2.3/server/
      default/tmp/deploy/tmp1441ab.ear-contents/chap2-ex3.jar
      17:37:19,467 INFO [EARDeployer] Started J2EE application: file:/D:/landmark/jbo
      ss-3.2.3/server/default/deploy/ab.ear
      17:37:19,467 INFO [MainDeployer] Deployed package: file:/D:/landmark/jboss-3.2.
      3/server/default/deploy/ab.ear
      17:37:19,467 INFO [URLDeploymentScanner] Started jboss.deployment:type=Deployme
      ntScanner,flavor=URL
      17:37:19,597 INFO [MainDeployer] Deployed package: file:/D:/landmark/jboss-3.2.
      3/server/default/conf/jboss-service.xml
      17:37:19,597 INFO [Server] JBoss (MX MicroKernel) [3.2.3 (build: CVSTag=JBoss_3
      _2_3 date=200311301445)] Started in 1m:52s:481ms
      //------

      ejb-jar.xml for std_axiom_ejb.jar next:
      //------
      <?xml version="1.0"?>

      <!DOCTYPE ejb-jar PUBLIC '-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 1.1//EN' 'http://java.sun.com/j2ee/dtds/ejb-jar_1_1.dtd'>

      <ejb-jar>
      <enterprise-beans>

      <ejb-name>landmark.axiom.server.beans.ClientSessionBean2</ejb-name>
      landmark.axiom.server.beans.StatefulHome
      landmark.axiom.server.beans.StatefulRemote
      <ejb-class>landmark.axiom.server.beans.ClientSessionBean2</ejb-class>
      <session-type>Stateful</session-type>
      <transaction-type>Container</transaction-type>


      <ejb-name>landmark.axiom.server.beans.UserMailbox</ejb-name>
      landmark.axiom.server.beans.UserMailboxHome
      landmark.axiom.server.beans.UserMailbox
      <ejb-class>landmark.axiom.server.beans.UserMailboxBean</ejb-class>
      <persistence-type>Bean</persistence-type>
      <prim-key-class>landmark.axiom.server.beans.UserMailboxKey</prim-key-class>
      False

      </enterprise-beans>
      </ejb-jar>
      //------

      syntax of application.xml and ejb-jar.xml files is correctly, but forum broke tag structure -((

      Any help is welcome.

        • 1. Re: JBoss doesn't deploy my EJB
          Sergey Vorov Newbie

          I've just found plausible reason of my problem.
          In my MANIFEST.MF for the ejb there are next:

          Class-Path: commons-beanutils-1.5.jar commons-collections-2.1.jar
          commons-digester-1.3.jar commons-logging-api-1.0.2.jar
          itext-1.02b.jar jasperreports-0.6.4.jar jcfield450K.jar
          jcommon-0.9.6.jar jcup.jar jdt-compiler.jar jFdfTk.jar
          jfreechart-0.9.21.jar jlex.jar landmark-axiom.jar
          landmark-bankbroker.jar landmark-bbproduction.jar
          landmark-commissions.jar landmark-commissions-engine.jar
          landmark-exchangemonitor.jar landmark-formsengine.jar
          landmark-importer.jar landmark-loader.jar
          landmark-parkbank.jar landmark-processengine.jar
          landmark-referral.jar landmark-reports.jar
          landmark-reportsengine.jar landmark-rulesengine.jar
          landmark-taskplanner.jar landmark-tools.jar
          nls_charset12.zip ojdbc14.jar


          It seems like this list is very long. And JBoss doesn't deploy my EJB and doen't throw any exceptions.

          But in what way I could set my ClassPath list? Or, please give me documnent's link about restrictions for MANIFEST.MF