1 Reply Latest reply on Sep 21, 2008 7:21 AM by Yaniv

    Too Many Open Files Exception (Socket accept failed)

    Yaniv Newbie

      Hi

      We are facing a repeating problem running JBoss App 4.2.2 GA (Jdk 1.6_02) on Red Hat linux.

      We are getting the following exception:

      2008-09-15 07:49:08,684 ERROR [org.apache.tomcat.util.net.JIoEndpoint] Socket accept failed
       java.net.SocketException: Too many open files
       at java.net.PlainSocketImpl.socketAccept(Native Method)
       at java.net.PlainSocketImpl.accept(PlainSocketImpl.java:384)
       at java.net.ServerSocket.implAccept(ServerSocket.java:453)
       at java.net.ServerSocket.accept(ServerSocket.java:421)
       at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(DefaultServerSocketFactory.java:61)
       at org.apache.tomcat.util.net.JIoEndpoint$Acceptor.run(JIoEndpoint.java:309)
       at java.lang.Thread.run(Thread.java:619)
      
      


      This did not happen on Jboss 4.0.2. i've tried looking for some answers in the forum but did not find any final conclusions or any solution that solves our problem. can anyone advice?


      forums ref:
      http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4131756#4131756
      https://jira.jboss.org/jira/browse/JBAS-5570
      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=72154
      http://www.seamframework.org/Community/TooManyOpenFilesJeopardizingSeamApplication


      Thanks

      Yaniv



        • 1. Re: Too Many Open Files Exception (Socket accept failed)
          Yaniv Newbie

          It seems that we might have found a solution.

          We have disabled the AJP 1.3 connector. to do so we commented out the following lines from the server.xml files which resides at "server\default\deploy\jboss-web.deployer"

          remove or comment the following lines

          <!-- Define an AJP 1.3 Connector on port 8009 -->
           <Connector port="8009" address="${jboss.bind.address}" protocol="AJP/1.3"
           emptySessionPath="true" enableLookups="false" redirectPort="8443" />