0 Replies Latest reply on Jan 27, 2009 3:25 PM by hemal yadav

    Error while deploying MDB on JBoss 4.2.3

    hemal yadav Newbie

      Hello ,
      I m trying to do parallel message processing through my mdb by making multiple instance of my MDB by @ActivationConfigProperty(propertyName = "ReceiverThreads", propertyValue = "5")on JBOSS but I m getting following error.


      org.jboss.deployment.DeploymentException: Error for ActivationSpec class org.jboss.resource.adapter.jms.inflow.JmsActivationSpec as JavaBean; - nested throwable: (java.beans.IntrospectionException: No property found for: ReceiverThreads on JavaBean: org.jboss.resource.adapter.jms.inflow.JmsActivationSpec@186b570(ra=null destination=queue/TestQueue isTopic=false tx=true durable=false reconnect=10 provider=java:/DefaultJMSProvider user=null maxMessages=1 minSession=1 maxSession=15 keepAlive=60000 useDLQ=true DLQHandler=org.jboss.resource.adapter.jms.inflow.dlq.GenericDLQHandler DLQJndiName=queue/AOMANotificationDLQ DLQUser=null DLQMaxResent=1))

      I also tried to configure MaxPoolSize with following Annotation
      @ActivationConfigProperty(propertyName = "MaxPoolSize", propertyValue = "5")
      got failed with same error as above saying property = MaxPoolSize" not found.

      Please help to resolve this error.

      Thanks In Advance,
      Hemal