1 Reply Latest reply on Nov 6, 2009 5:56 AM by walter mauritz

    Using an old EJB ?1.2? in a jboss 5.1

    walter mauritz Newbie

      I got an old application which I am moving to Jboss AS 5.1GA for security reasons mainly.

      history:
      orion
      jboss 3.2.3
      jboss 3.2.8.SP1

      On startup jboss tells me:
      FileNotFoundException: http://java.sun.com/j2ee/dtds/ejb-jar_1_2.dtd

      So I looked into my JARs and found an ejb-jar.xml with this header: (I also have some 2.0 ejb-jar.xml which do work):

      <!DOCTYPE ejb-jar PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 1.2//EN" "http://java.sun.com/j2ee/dtds/ejb-jar_1_2.dtd">
      ...

      On jboss 5.1 it complains for not being able to resolve this DTD.

      1) Where can I find this DTD?

      2) Is there another DTD to which I can safely move?
      The XML seems not to be compatible with DTD 2.0 or 1.1