5 Replies Latest reply on Jan 6, 2010 10:18 AM by Jean-Frederic Clere

    error mod_cluster

    Matjaz Lenarcic Newbie

      How to solve this problem?

      [DefaultMCMPHandler] [] Error [MEM: MEM: Can't read host alias: {4}]

        • 1. Re: error mod_cluster
          Jean-Frederic Clere Master

          Do you have a Host defined in the server.xml?

          • 2. Re: error mod_cluster
            Matjaz Lenarcic Newbie

            my server.xml

             

                    <Host name="localhost"
                       autoDeploy="false" deployOnStartup="false" deployXML="false"
                       configClass="org.jboss.web.tomcat.security.config.JBossContextConfig"
                       >

                        <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
                            cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
                            transactionManagerObjectName="jboss:service=TransactionManager" />

                     </Host>
                     <Host name="zzzzz" autoDeploy="false" deployOnStartup="false" deployXML="false">
                            <Alias>xxxxx.xxxx.xx</Alias>
                            <Alias>yyyyy.xxxx.xx</Alias>
                           

                                <DefaultContext cookies="true" crossContext="true" override="true"/>
                     <Valve className="org.jboss.web.tomcat.service.jca.CachedConnectionValve"
                            cachedConnectionManagerObjectName="jboss.jca:service=CachedConnectionManager"
                            transactionManagerObjectName="jboss:service=TransactionManager" />
                     </Host>

            • 3. Re: error mod_cluster
              Jean-Frederic Clere Master

              that looks to be something wrong on the httpd side.

              In httpd.conf put LogLevel debug and look to the ENABLE-APP message on should cause the error. Copy + Paste it in forum.

              • 4. Re: error mod_cluster
                Matjaz Lenarcic Newbie
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1397): manager_trans INFO (/)
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1899): manager_handler INFO (/) processing: ""
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1940): manager_handler INFO  OK
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1397): manager_trans CONFIG (/)
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1899): manager_handler CONFIG (/) processing: "JVMRoute=node1&Timeout=60&Port=8009&Balancer=bintest&Domain=bintest&Host=10.8.25.114&smax=50&Type=ajp&ttl=60000&ping=20"
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1940): manager_handler CONFIG  OK
                [Wed Jan 06 06:46:46 2010] [debug] mod_manager.c(1397): manager_trans ENABLE-APP (/)
                [Wed Jan 06 06:45:40 2010] [debug] mod_manager.c(1899): manager_handler ENABLE-APP (/) processing: "JVMRoute=node1&Alias=xxxxx,yyyyy,zzzz&Context=%2f"
                [Wed Jan 06 06:45:40 2010] [debug] mod_manager.c(1601): manager_handler ENABLE-APP error: MEM: Can't read host alias
                • 5. Re: error mod_cluster
                  Jean-Frederic Clere Master

                  It seems that is a bug in both 1.0.2 and 1.1.0 Beta1 I have created a JIRA.

                  https://jira.jboss.org/jira/browse/MODCLUSTER-121