1 Reply Latest reply on Nov 16, 2009 9:47 AM by Paul Ferraro

    Use with tomcat 5.5

    Rajah Harris Newbie

      I'm trying to setup mod_cluster (1.0.2 GA) on it's own server and then have it go out and attach itself to a legacy server that has tomcat 5.5.28 (i have it successfully working with a tomcat 6.0 server) on it. As you may know the modclusterlistener is failing on build. I want to know if there is anything that i can do or an earlier version mod_cluster that i can use to have it work properly with tomcat 5.5.

      Thanks.

        • 1. Re: Use with tomcat 5.5
          Paul Ferraro Master

          I think you mean that the ModClusterListener fails on start, not build, right? You're probably getting a java.lang.NoSuchMethodError during startup, right?
          Actually, there is a way to get mod_cluster to work with tomcat 5.5. In version 1.1.0.Beta1, there is an SPI for the server side code. Currently, the only implementation is for jbossweb 2.2.x & Tomcat 6.0. Here's how you would create a Tomcat 5.5 service provider implementation:

          * Override the CatalinaConnector, CatalinaContext, CatalinaEngine, CatalinaHost, and CatalinaServer classes from the org.jboss.modcluster.catalina package, fixing adjustments any api incompatibilities. You'll also want to override methods such as CatalinaServer.getEngines(), CatalinaEngine.getHosts(), etc. such that they return instances of your classes.
          * Override org.jboss.modcluster.catalina.CatalinaEventHandlerAdapter. This class is what adapts catalina lifecycle events to the mod_cluster's ContainerEventHandler interface. You'll want to change any references to Catalina* objects to use your implementations from above.
          * Override org.jboss.modcluster.catalina.ModClusterListener, and modify the default constructor to use your overridden CatalinaEventHandlerAdapter.
          * Change the listener className in your server.xml to use your listener implementation defined above.

          That should do it.