2 Replies Latest reply on Nov 30, 2001 8:56 PM by Andrea

    java.lang.NoClassDefFoundError: org/jboss/docs/interest/Inte

    mark Newbie

      I'm trying to make the first example work and I get the following error when I run the InterestServlet example:

      Error: 500
      Location: /interest/InterestServlet
      Internal Servlet Error:

      java.lang.NoClassDefFoundError: org/jboss/docs/interest/Interest
      at java.lang.Class.newInstance0(Native Method)
      at java.lang.Class.newInstance(Unknown Source)
      at org.apache.tomcat.core.ServletWrapper.loadServlet(ServletWrapper.java:268)
      at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:289)
      at org.apache.tomcat.core.Handler.service(Handler.java:254)
      at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
      at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:812)
      at org.apache.tomcat.core.ContextManager.service(ContextManager.java:758)
      at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:213)
      at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
      at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:501)
      at java.lang.Thread.run(Unknown Source)

      Please can someone help me and tell me if this is a classpath issue or what.

        • 1. Re: java.lang.NoClassDefFoundError: org/jboss/docs/interest/
          Andrea Newbie

          Okay, the solution is to copy the interest.ear file to %JBOSS_DIST%\deploy!

          • 2. java.lang.NoClassDefFoundError: org/jboss/docs/interest/Inte
            Andrea Newbie

            I'm trying to make the first example work and I get the following error when I run the InterestServlet example:

            Error: 500
            Location: /interest/InterestServlet
            Internal Servlet Error:

            java.lang.NoClassDefFoundError: org/jboss/docs/interest/Interest
            at java.lang.Class.newInstance0(Native Method)
            at java.lang.Class.newInstance(Unknown Source)
            at org.apache.tomcat.core.ServletWrapper.loadServlet(ServletWrapper.java:268)
            at org.apache.tomcat.core.ServletWrapper.init(ServletWrapper.java:289)
            at org.apache.tomcat.core.Handler.service(Handler.java:254)
            at org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
            at org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:812)
            at org.apache.tomcat.core.ContextManager.service(ContextManager.java:758)
            at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:213)
            at org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)
            at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:501)
            at java.lang.Thread.run(Unknown Source)

            Please can someone help me and tell me if this is a classpath issue or what.