9 Replies Latest reply on Jul 31, 2002 10:32 AM by hongmei

    JSP CLASSPATH

    Aanchal Newbie

      When i run the Interest example as an application , it works fine.Now when i try runnin it using a JSP file,it gives me an import error that the classpath for Interest and InterestHome cannot be found.I fail to understand,which classpath i havent set.Please Help and tell me exactly what should i do inorder to run my JSP file.

        • 1. Re: JSP CLASSPATH
          Anthony Burns Newbie

          I have same exact problem

          • 2. Re: JSP CLASSPATH
            Jules Gosnell Novice


            2.4.4 or 3.0 ?

            Jetty or Tomcat ?

            If Tomcat - try Jetty.

            If Jetty AND 3.0 - I will fix it.


            Jules

            • 3. Re: JSP CLASSPATH
              shivva Newbie

              Hi
              i also got the same problem.
              am using jboss3 with tomcat.
              please help

              Thanks in advance
              shivva

              • 4. Re: JSP CLASSPATH
                Randy Gordon Newbie


                Yeah, I reported this problem on this forum a few
                weeks ago but got no response. The problem seems
                to be with the JBoss 3.0/Tomcat distribution.

                JSPs can't see classes that live in JARs packaged
                at the EAR level.

                Works with Websphere, JBoss 2.0 and every other
                app server we've tried.

                I'm eagerly awaiting a fix so we can start using JBoss 3.0.

                • 5. Re: JSP CLASSPATH
                  DRAI William Newbie

                  I'm also using JBoss 3 with libs at EAR level and I had this problem with the JSP classpath :

                  You have to add a MANIFEST.MF in the META-INF of your webapp like this :

                  Class-Path: ./lib/your.jar


                  Hope this helps

                  • 6. Re: JSP CLASSPATH
                    Randy Gordon Newbie


                    We DO have a reference to the library JAR in the
                    META-INF/MANIFEST.MF of the webapp's WAR file.

                    In our case the library JAR lives at the root of the EAR,
                    not in ./lib, so we have declared in the MANIFEST.MF:

                    Class-Path: x.jar

                    It does not work with JBoss3.0/Tomcat.

                    It works with JBoss2.0/Tomcat and Websphere.

                    • 7. Re: JSP CLASSPATH
                      Ben Brantley Newbie

                      Hello,

                      I'm having all the of the same problems mentioned above, with either Jboss 3.0.0 Tomcat OR Jetty. In either case, if the JSP in the WAR tries to reference any classes I expect to be loaded via the manifest class-path, the compile fails. Is there ANY solution to this on the horizon?

                      I don't have the option to include every since extension JAR in my WEB-INF/lib directory.

                      Thanks,

                      Ben

                      • 8. Re: JSP CLASSPATH
                        Julian Gosnell Expert

                        If you are using the MANIFEST.MF classpath tag, I've heard that if there is no new line at the end, it will not be picked up...

                        Does that help ?

                        Jules

                        • 9. Re: JSP CLASSPATH
                          hongmei Newbie

                          Hi, there.
                          I saw you post a question about "JSP CLASSPATH", I met a problem here about JSP too. I have a .ear file which consists of one .war file and .jar file. I can deploy successfully my ear file, but when I access my JSP file, it can not find any classes which I did saw in .war file.

                          Do you know what's wrong? or this is the problem you mentioned.

                          Please help me.

                          Thanks,
                          hongmei