2 Replies Latest reply on Oct 18, 2001 12:43 AM by Oytan022

    Proxy class not found??

    Frank Xia Newbie

      Hi,

      Anyone encount the similar problem?

      I installed JBOSS 2.4.0 with Tomcat 3.2.3. The EJB was deployed but returned the following error message,

      [EmbeddedTomcatSX] 2001-10-02 16:53:30 - Ctx( /examples ): Exception in: R( /examples + /servlet/com.esri.servlet.EJBMapServlet + null) - java.lang.NoClassDefFoundError: $Proxy10
      at sun.reflect.GeneratedSerializationConstructorAccessor61.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.io.ObjectStreamClass.newInstance(Unknown Source)
      at java.io.ObjectInputStream.readOrdinaryObject(Unknown Source)
      at java.io.ObjectInputStream.readObject0(Unknown Source)
      at java.io.ObjectInputStream.readObject(Unknown Source)
      when I tried to acccess from a servlet running in the Tomcat bundled with JBOSS.

      However, I have no problem at all if I run the same servlet in a separate Tomcat (in a different port).

      any help/advice is greatly appreciated

      Frank