2 Replies Latest reply on Jan 30, 2002 7:55 PM by Renaud Bruyeron

    Additional jars not found in WEB-INF/lib

    Joel Riedesel Newbie

      I've just updated my source tree as of this morning.
      The Jetty with the latest JBoss 3.0 stuff doesn't
      handle, apparently, more than the main jar file
      in the WEB-INF/lib directory. My main servlet is
      being found but secondary classes in a different
      jar file in that directory are not being found.

      Jetty 4.0D2 that I run separately (outside of JBoss)
      does handle this.

      So, what's the deal?

        • 1. Re: Additional jars not found in WEB-INF/lib
          Jules Gosnell Novice

          If this is true, I should take a look at it.

          I'm very busy at the moment - if you had a testcase you could mail me it would be a great help.

          Cheers,

          Jules

          • 2. Re: Additional jars not found in WEB-INF/lib
            Renaud Bruyeron Newbie

            I have a similar problem with jboss-RH (checked out 1h ago): the deployment of my webapp fails when the MainDeployer tries to deploy struts.jar...??

            The .ear is just a wrapper around my .war with a simple application.xml:


            <web-uri>zg.war</web-uri>
            <context-root>/zg</context-root>



            The war is very simple: struts.jar is in /WEB-INF/lib/ with Xalan and Xerces jars, and my own classes are in /WEB-INF/classes

            Looking at the MainDeployer.java, it looks like something is not right when subDeploying. But it's late, so I am not going further than this bug report :-)

            Here's the output on the console during deployment:

            00:45:43,566 INFO [MainDeployer] Auto deploying: file:/D:/temp/jboss/jboss-all/build/output/jboss-3.0.0DR1/deploy/zg.ear
            00:45:43,727 INFO [MainDeployer] Auto deploying: file:D:/temp/jboss/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/zg.war
            00:45:43,977 ERROR [MainDeployer] Error in subDeployment
            java.io.FileNotFoundException: D:\temp\jboss\jboss-all\build\output\jboss-3.0.0DR1\tmp\deploy\WEB-INF\lib\struts.jar (The system cannot find the path specified)

            at java.io.FileOutputStream.open(Native Method)
            at java.io.FileOutputStream.(Unknown Source)
            at java.io.FileOutputStream.(Unknown Source)
            at java.io.FileOutputStream.(Unknown Source)
            at org.jboss.deployment.MainDeployer.deploySubPackages(MainDeployer.java:578)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:373)
            at org.jboss.deployment.MainDeployer.deploySubPackages(MainDeployer.java:590)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:373)
            at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:348)
            at org.jboss.deployment.MainDeployer.scan(MainDeployer.java:254)
            at org.jboss.deployment.MainDeployer.run(MainDeployer.java:238)
            at java.lang.Thread.run(Unknown Source)