3 Replies Latest reply on Jan 11, 2002 11:46 AM by Marcus Brito

    Servlet Exception: DistributedSessionManager

    Marcus Brito Novice

      Hello, folks.

      I'm trying to develop a small application user JBoss (3.0.0alpha checked out from CVS on 01.08) + Struts. I was doing some EJB's, writing a JSP or two.

      It seemed to be OK until now. The problem is: I don't even know what I've done to trigger the error. I've tried to disable struts servlet configuration, to no avail. It seems that there's nothing to do with Struts at all.

      The error occurs everytime I try to access a servlet or jsp page. The stack trace:

      2002-01-09 11:23:54,754 WARN [org.jboss.jetty.Jetty] WARNING: Servlet Exception for /auth-manager/test?suite=com.tld.auth.tests.AuthManagerTest
      java.lang.NullPointerException
       at org.jboss.jetty.DistributedSessionManager$DistributedSession.activate(DistributedSessionManager.java:308)
       at org.jboss.jetty.DistributedSessionManager$DistributedSession.activate(DistributedSessionManager.java:299)
       at org.jboss.jetty.DistributedSessionManager$DistributedSession.<init>(DistributedSessionManager.java:293)
       at org.jboss.jetty.DistributedSessionManager.getHttpSession(DistributedSessionManager.java:195)
       at org.mortbay.jetty.servlet.ServletHandler.getHttpSession(ServletHandler.java:466)
       at org.mortbay.jetty.servlet.ServletHttpRequest.getSession(ServletHttpRequest.java:492)
       at org.mortbay.jetty.servlet.ServletHandler.newFacades(ServletHandler.java:444)
       at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:515)
       at org.mortbay.http.HttpContext.handle(HttpContext.java:1265)
       at org.mortbay.http.HttpContext.handle(HttpContext.java:1219)
       at org.mortbay.http.HttpServer.service(HttpServer.java:725)
       at org.mortbay.http.HttpConnection.service(HttpConnection.java:745)
      ...
      


      The stack trace goes a bit further, but I think that can be enough. If needed, I can provide all my deployment descriptors, source code and any other information needed to solve this problem.

        • 1. Re: Servlet Exception: DistributedSessionManager
          Marcus Brito Novice

          Just to add a little more info, I've found the following entry digging the server log. I hope this helps finding the error.

          [org.jboss.jetty.EJBDistributedStore] WARNING: Support for EJB-based Distributed HttpSessions does not appear to be loaded
          


          • 2. Re: Servlet Exception: DistributedSessionManager
            Marcus Brito Novice

            Well, here I am again. I've uncovered a new stack trace with a new exception. Here it goes.

            java.lang.NoSuchMethodError: org.mortbay.jetty.servlet.HashSessionManager: method access$001(Lorg/jboss/jetty/DistributedSessionManager;)I not found
             at org.jboss.jetty.DistributedSessionManager$DistributedSession.<init>(DistributedSessionManager.java:281)
             at org.jboss.jetty.DistributedSessionManager.newHttpSession(DistributedSessionManager.java:204)
             at org.mortbay.jetty.servlet.ServletHandler.newHttpSession(ServletHandler.java:472)
             at org.mortbay.jetty.servlet.ServletHttpRequest.getSession(ServletHttpRequest.java:499)
             at org.mortbay.jetty.servlet.ServletHttpRequest.getSession(ServletHttpRequest.java:521)
            

            (...)

            it goes on.

            • 3. Re: Servlet Exception: DistributedSessionManager
              Marcus Brito Novice

              Well, couldn't find the bug but at least solved my problem. The app works fine if I remove the tag from web.xml