2 Replies Latest reply on Jan 29, 2002 10:53 AM by Kip Obenauf

    JSP not updated after deploy

    Kip Obenauf Newbie

      Using JBoss-2.4.4_Tomcat-4.0.1-beta. Serving pages through Apache 1.3.20 using mod_jk. I'm developing in JBuilder and deploying using Ant.

      About 60% of the time, after making changes to a JSP and deploying, the changes don't show up in my browser. I've completely closed the browser and cleared cache, but problem persists.

      I know the file is actually making it to JBoss. After deploying, I look under jboss/tmp/deploy/Default/mywar.war, and I see a new web dir, and the JSP there does have my latest change.

      I've looked in the JBoss server.log for deploy errors but everything looks normal.

      After refreshing the browser, I look again in server.log, but still see nothing surprising. The status for the file is reported in server.log and in httpd.log sometimes as 200 OK and sometimes as 304(Not Modified), so it does seem like there might be a caching issue, or somehow JBoss is failing to see the file as modified from the last time it served it.

      I've tried stopping and restarting JBoss, and I've also deleted the war file before redeploying it, but it still fails to serve the new page.

      Any suggestions?

        • 1. Re: JSP not updated after deploy
          John Twomey Newbie

          Try adding this to your jboss.jcml;

          <!-- Uncomment to add embedded catalina service -->










          In addition - loose the beta and get the final of this version (jboss-2.4.4_Tomcat-4.0.1)
          I think I ran into the same issue with the beta and I THINK I read something about it being dealt with in the final release.

          JT

          • 2. Re: JSP not updated after deploy
            Kip Obenauf Newbie

            Thanks for the tip!

            Is there a place I can set 'reloadable=true' on a global level?

            Maybe more importantly, can you point me towards documentation for this? I've had trouble finding documentation that is current or in any kind of detail. (The documentation that came with the distribution I have is scant and has references to settings that don't even make sense in my version. They obviously refer to earlier versions of the product.) Maybe there's something I've overlooked. I know there's up-to-date documentation for sell, but charging for a necessary component of a "free" product is really a bait-and-switch. A search through the "volunteer-maintained" documentation yields 0 hits for "reloadable".