2 Replies Latest reply on Feb 5, 2002 12:47 PM by Jules Gosnell

    Problem deploying EAR with JBoss 3.0/Jetty

    Michael Collins Newbie

      I got past my earlier problem. It was a descriptor issue.

      The problem that I am now having is with my EAR file. I have a simple EAR file containing one EJB and one web component. The EJB and the web component deploy fine when I copy the JAR or WAR file to the deploy directory.

      When I package them together in the same EAR file, I am getting the following:

      2002-02-02 23:07:41,807 INFO [org.jboss.deployment.MainDeployer] Auto deploying: file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/deploy/common-1.0-test.ear
      2002-02-02 23:07:41,827 DEBUG [org.jboss.system.UnifiedClassLoader] New UCL with url file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/55.common-1.0-test.ear
      2002-02-02 23:07:41,827 TRACE [org.jboss.system.ServiceLibraries] Libraries adding UnifiedClassLoader -775649582 key URL file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/55.common-1.0-test.ear
      2002-02-02 23:07:41,827 INFO [org.jboss.deployment.MainDeployer] using deployer org.jboss.deployment.EARDeployer@405d3b
      2002-02-02 23:07:42,308 INFO [org.jboss.deployment.MainDeployer] Auto deploying: file:C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/common-1.0-test.war
      2002-02-02 23:07:42,338 DEBUG [org.jboss.system.UnifiedClassLoader] New UCL with url file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/56.common-1.0-test.war
      2002-02-02 23:07:42,348 TRACE [org.jboss.system.ServiceLibraries] Libraries adding UnifiedClassLoader -564281371 key URL file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/56.common-1.0-test.war
      2002-02-02 23:07:42,348 INFO [org.jboss.deployment.MainDeployer] using deployer org.jboss.jetty.JettyService@14013
      2002-02-02 23:07:42,348 ERROR [org.jboss.jetty.JettyService] Problem in init
      java.lang.NullPointerException
      at org.jboss.web.AbstractWebContainer.init(AbstractWebContainer.java:182)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:374)
      at org.jboss.deployment.MainDeployer.deploySubPackages(MainDeployer.java:598)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:377)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:351)
      at org.jboss.deployment.MainDeployer.scan(MainDeployer.java:254)
      at org.jboss.deployment.MainDeployer.run(MainDeployer.java:238)
      at java.lang.Thread.run(Unknown Source)
      2002-02-02 23:07:42,348 DEBUG [org.jboss.deployment.MainDeployer] Watching new file: file:C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/tmp/deploy/common-1.0-test.war
      2002-02-02 23:07:42,358 DEBUG [org.jboss.deployment.MainDeployer] Watching new file: file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/deploy/common-1.0-test.ear
      2002-02-02 23:07:42,358 ERROR [org.jboss.deployment.MainDeployer] Couldn't deploy URL file:/C:/java/jboss-3.0-src/jboss-all/build/output/jboss-3.0.0DR1/deploy/common-1.0-test.ear
      org.jboss.deployment.DeploymentException
      at org.jboss.web.AbstractWebContainer.init(AbstractWebContainer.java:232)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:374)
      at org.jboss.deployment.MainDeployer.deploySubPackages(MainDeployer.java:598)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:377)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:351)
      at org.jboss.deployment.MainDeployer.scan(MainDeployer.java:254)
      at org.jboss.deployment.MainDeployer.run(MainDeployer.java:238)
      at java.lang.Thread.run(Unknown Source)

      When I connect to the admin screen at port 8082, I can see that my EJB was deployed, but the WAR file is not because of the above exception.

      Any ideas? Thanks.