9 Replies Latest reply on Feb 19, 2002 12:42 PM by Enrique Rodriguez

    Apache - Catalina - JBoss - Win 2K Configuration

    Jeovanny Newbie

      I have followed the thread "May I integrate Apache + Tomcat + JBoss ?" At the end, it is built on Linux and am a little confused on converting it to a Windows install.

      Does anyone have a step-by-step on how to configure:

      Apache 1.3.23
      Catalina
      JBoss

      on Windows 2000 Professional using mod_jk?

      Thanks!

        • 1. Re: Apache - Catalina - JBoss - Win 2K Configuration
          Enrique Rodriguez Newbie

          i've configured it. You have all the info in this thread http://main.jboss.org/thread.jsp?forum=50&thread=8591

          if you have any problem i try to help you, but i think, that in this thread you have all the info that you need.

          bye, Enrique

          • 2. Re: Apache - Catalina - JBoss - Win 2K Configuration
            Jeovanny Newbie

            I have followed all the configuration changes in that thread. JBoss/Catalina is loading the Ajp13Processor as seen below.

            [INFO,EmbeddedCatalinaServiceSX] Ajp13Connector[8009] Opening server socket on a
            ll host IP addresses
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Connector[8009] Starting background thread

            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][0] Starting background thr
            ead
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][0] Background thread has
            been started
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][1] Starting background thr
            ead
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][1] Background thread has
            been started
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][2] Starting background thr
            ead
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][2] Background thread has
            been started
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][3] Starting background thr
            ead
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][3] Background thread has
            been started
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] Starting background thr
            ead
            [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] Background thread has
            been started
            [INFO,EmbeddedCatalinaServiceSX] OK
            [INFO,EmbeddedCatalinaServiceSX] Started

            I can get it to work by using http://localhost:8080/jboss/

            However, http://localhost/jboss/ gives me an HTTP 404 Not Found Error.

            Any suggestions?

            • 3. Re: Apache - Catalina - JBoss - Win 2K Configuration
              Enrique Rodriguez Newbie

              ok your jboss+catalina config is ok, because you get the info in the logs.

              I think that your problen is on the apache. Give me more info about the httpd.conf.

              Remenber that this lines have to be at the end of the file

              JkWorkersFile "C:/jboss/catalina/conf/workers.properties"
              JkLogFile "C:/jboss/catalina/logs/mod_jk.log"

              #
              # Log level to be used by mod_jk
              #
              JkLogLevel error

              #
              # Root context mounts for Tomcat
              #
              JkMount /*.jsp ajp13
              JkMount /servlet/* ajp13
              JkMount /jboss/* ajp13
              JkMount /jboss/servlet/* ajp13

              • 4. Re: Apache - Catalina - JBoss - Win 2K Configuration
                kalaiselvan Newbie

                I add following lines in my httpd.conf

                JkWorkersFile "E:/JBoss-2.4.4_Tomcat-4.0.1/jboss/catalina/conf/workers.properties"
                JkLogFile "E:/JBoss-2.4.4_Tomcat-4.0.1/jboss/catalina/logs/mod_jk.log"

                JkMount /*.jsp ajp13
                JkMount /servlet/* ajp13
                JkMount /jboss/* ajp13
                JkMount /jboss/servlet/* ajp13

                but i found error when i starting my Apache.exe

                Syntax error on line 1023 of d:/program files/apache group/apache/conf/httpd.conf:
                Invalid command 'JkWorkersFile', perhaps mis-spelled or defined by a module not included in the server configuration

                What i'm missing????

                • 5. Re: Apache - Catalina - JBoss - Win 2K Configuration
                  kalaiselvan Newbie

                  Also i havent "mod_jk.conf" or "mod_jk.so" and "mod_jk.h" in my D:\Program Files\Apache Group\Apache\modules directory.

                  Just a hour before i dowloaded a new version of
                  apache_1.3.23-win32-x86-no_src.exe from http://httpd.apache.org/

                  but in my JBoss-2.4.4_Tomcat-4.0.1 in changed in my jboss.jcml like







                  its not giving any error.

                  [INFO,EmbeddedCatalinaServiceSX] Starting
                  [INFO,EmbeddedCatalinaServiceSX] Starting EmbeddedCatalinaSX....
                  [INFO,EmbeddedCatalinaServiceSX] Building Http engine and connector
                  [INFO,Default] Apache Tomcat/4.0.1
                  [INFO,EmbeddedCatalinaServiceSX] HttpConnector Opening server socket on all host IP addresses
                  [INFO,EmbeddedCatalinaServiceSX] HttpConnector[8080] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] HttpProcessor[8080][0] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] HttpProcessor[8080][1] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] HttpProcessor[8080][2] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] HttpProcessor[8080][3] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] HttpProcessor[8080][4] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Connector[8009] Opening server socket on all host IP address
                  es
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Connector[8009] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][0] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][0] Background thread has been started
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][1] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][1] Background thread has been started
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][2] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][2] Background thread has been started
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][3] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][3] Background thread has been started
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] Starting background thread
                  [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] Background thread has been started
                  [INFO,EmbeddedCatalinaServiceSX] OK
                  [INFO,EmbeddedCatalinaServiceSX] Started

                  but if open the page

                  http://localhost:8080/jboss -->>> working fine but
                  http://localhost/jboss -->>>> no webpage found error

                  What i should do to configure jboss-tomcat with apache???

                  Thanx
                  Kalaiselvan

                  • 6. Re: Apache - Catalina - JBoss - Win 2K Configuration
                    Enrique Rodriguez Newbie

                    do you java the mod_jk.dll in the modules directory of apache?

                    The spqlling error look strange.

                    Jboss+Tomcat config is ok, the problem is only in apache.

                    • 7. Re: Apache - Catalina - JBoss - Win 2K Configuration
                      kalaiselvan Newbie

                      No i dont have mod_jk.dll

                      • 8. Re: Apache - Catalina - JBoss - Win 2K Configuration
                        kalaiselvan Newbie

                        No i dont have mod_jk.dll in Apache directory

                        I have
                        Apache 1.3.23
                        JBoss-2.4.4_Tomcat-4.0.1

                        • 9. Re: Apache - Catalina - JBoss - Win 2K Configuration
                          Enrique Rodriguez Newbie

                          you have to download it from tomcat website