3 Replies Latest reply on Feb 21, 2002 9:59 AM by Mike O'Connor

    JBOSS/Catalina error

    Mike O'Connor Newbie

      Here is an interesting one.. I have an enterprise app properly enclosed in an ear file. It works just fine under JBoss-2.4.1_Tomcat-3.2.3, but not under JBoss-2.4.4_Tomcat-4.0.1... I get the following error when i hit the servlet using IE (curiously, it works fine with Opera).

      [INFO,EmbeddedCatalinaServiceSX] StandardHost[localhost]: MAPPING configuration error for request URI
      [ERROR,EmbeddedCatalinaServiceSX] HttpProcessor[8080][3] process.invoke java.lang.NullPointerException at org.apache.catalina.valves.ErrorDispatcherValve.status(ErrorDispatcherValve.java:280) at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:180)
      at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:564)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:170) at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:564)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:163)
      at org.apache.catalina.core.StandardPipeline.invokeNext(StandardPipeline.java:566)
      at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:472)
      at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:943)
      at org.apache.catalina.connector.http.HttpProcessor.process(HttpProcessor.java:1011)
      at org.apache.catalina.connector.http.HttpProcessor.run(HttpProcessor.java:1106)
      at java.lang.Thread.run(Unknown Source)

      Any ideas?

        • 1. Re: JBOSS/Catalina error
          Mike O'Connor Newbie

          oh, and the page does come up in the browser, however, not too long after, as i navigate through the application, IE stops responding..

          • 2. Re: JBOSS/Catalina error
            Sten Karlson Newbie

            The problem might be that there is no root context deployed.

            Check the FAQ forum.

            Sten Karslon

            • 3. Re: JBOSS/Catalina error
              Mike O'Connor Newbie

              Maybe i should have structured my question better...

              The above exception occurs only when you hit the servlet using "Internet Explorer". Using the Opera web browser or the Netscape web browser, this servlet works fine. This problem is specific to the JBoss-2.4.4_Tomcat-4.0.1 and Internet Explorer only! It works just fine under JBoss-2.4.1_Tomcat-3.2.3 with ANY web browser.

              To clarify, i do indeed see the servlet in my browser, I am able to log in to my servlet, i am able to navigate throughout my application as a whole... for a bit. Eventually, IE just stops responding. Every time i go to a new page, or a page is refreshed (when i use page, i mean a servlet page), i get that exception.

              So, my question is, still, what does catalina not like about the way IE communicates with the servlet such that it throws that particular exception, eventually causing IE to die... And i am using this forum, and not asking at apache because this is an enterprise application in which I am using JBoss paired with Catalina..