5 Replies Latest reply on Jul 9, 2002 8:37 AM by balaji kuduva

    Problem in Jboss ( jetty) - struts

    balaji kuduva Newbie

      hi ,

      i was running my application well in resin server with struts architecture ..

      i tried to deploy the same application jboss - jetty server it dosent deploy properly...

      all my files are placed in proper directory and struts-config.xml is also properly updated...


      1. do we have to change any configuration files in jetty server ?

      2. do we have to include "action form bean" in each and every form we are creating ?

      3. if i use the custom tag lib. in jsp code this gives the error in browser as ..


      "HTTP ERROR: 500 /Scheme/SchemeDefnStep1.jsp(88,47) Attribute value should be quoted
      RequestURI=/crm/schDefnStep1.action :"

      plase help me in solving the above problem..




        • 1. Re: Problem in Jboss ( jetty) - struts
          Joel Vogt Master

          Is this in jboss 3 or 2.4.x?

          I know for sure that jboss 2.4.x just goes with struts, havn't tested 3 yet.
          Could you also post the struts tag that seems to be causing the trouble? (Or maybe a minimal jsp page that reproduces the error?)

          • 2. Re: Problem in Jboss ( jetty) - struts
            Julian Gosnell Expert

            and a section of log showing the deployment errors - if it doesn't deploy properly, it is unlikely to work properly.

            Thanks,

            Jules

            • 3. Re: Problem in Jboss ( jetty) - struts
              balaji kuduva Newbie

              hai ,

              this are the configuration files

              1.web.xml ( placed in WEB-INF\)
              ----------------------------------
              <web-app>

              <servlet-name>action</servlet-name>
              <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
              <init-param>
              <param-name>application</param-name>
              <param-value>ApplicationResources</param-value>
              </init-param>
              .......
              .......
              <servlet-mapping>
              <servlet-name>action</servlet-name>
              <url-pattern>*.action</url-pattern>
              </servlet-mapping>
              .....
              ....

              <taglib-uri>/WEB-INF/struts.tld</taglib-uri>
              <taglib-location>/WEB-INF/struts.tld</taglib-location>


              <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
              <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>

              .....
              </web-app>
              ------------------------------------------------
              2.struts-conf.xml ( placed in WEB-INF\)
              .......
              <action-mappings>




              </action-mappings>
              .....
              -----------------------------------

              3. the jsp page(loginBack.jsp) calling action

              <%@ page language="java" %>
              <%@ page import="java.util.*"%>
              <%@ page import="TSIPack.logic.*"%>
              <%@ page import="TSIPack.view.*"%>
              <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
              <%@ taglib uri="/WEB-INF/struts-form.tld" prefix="form" %>
              <%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>




              ...............
              .............
              ................
              this will have a text user name and password..
              and a submit button..
              ------------------------------------------------

              4. this is the path where i am calling th action servlet
              -------------------------------------------------------
              /home/jboss-3.0.0/server/default/deploy/TSI.war/WEB-INF/classes/TSIPack/actions/
              ----------------------------------------------------

              currently i am using jboss 3 verson

              please help me

              • 4. Re: Problem in Jboss ( jetty) - struts
                balaji kuduva Newbie

                hai ,

                this are the configuration files

                1.web.xml ( placed in WEB-INF\)
                ----------------------------------
                <web-app>

                <servlet-name>action</servlet-name>
                <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
                <init-param>
                <param-name>application</param-name>
                <param-value>ApplicationResources</param-value>
                </init-param>
                .......
                .......
                <servlet-mapping>
                <servlet-name>action</servlet-name>
                <url-pattern>*.action</url-pattern>
                </servlet-mapping>
                .....
                ....

                <taglib-uri>/WEB-INF/struts.tld</taglib-uri>
                <taglib-location>/WEB-INF/struts.tld</taglib-location>


                <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
                <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>

                .....
                </web-app>
                ------------------------------------------------
                2.struts-conf.xml ( placed in WEB-INF\)
                .......
                <action-mappings>




                </action-mappings>
                .....
                -----------------------------------

                3. the jsp page(loginBack.jsp) calling action

                <%@ page language="java" %>
                <%@ page import="java.util.*"%>
                <%@ page import="TSIPack.logic.*"%>
                <%@ page import="TSIPack.view.*"%>
                <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
                <%@ taglib uri="/WEB-INF/struts-form.tld" prefix="form" %>
                <%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>




                ...............
                .............
                ................
                this will have a text user name and password..
                and a submit button..
                ------------------------------------------------

                4. this is the path where i am calling th action servlet
                -------------------------------------------------------
                /home/jboss-3.0.0/server/default/deploy/TSI.war/WEB-INF/classes/TSIPack/actions/
                ----------------------------------------------------

                currently i am using jboss 3 verson

                please help me

                • 5. Re: Problem in Jboss ( jetty) - struts
                  balaji kuduva Newbie

                  hai ,

                  this are the configuration files

                  1.web.xml ( placed in WEB-INF\)
                  ----------------------------------
                  <web-app>

                  <servlet-name>action</servlet-name>
                  <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
                  <init-param>
                  <param-name>application</param-name>
                  <param-value>ApplicationResources</param-value>
                  </init-param>
                  .......
                  .......
                  <servlet-mapping>
                  <servlet-name>action</servlet-name>
                  <url-pattern>*.action</url-pattern>
                  </servlet-mapping>
                  .....
                  ....

                  <taglib-uri>/WEB-INF/struts.tld</taglib-uri>
                  <taglib-location>/WEB-INF/struts.tld</taglib-location>


                  <taglib-uri>/WEB-INF/struts-bean.tld</taglib-uri>
                  <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>

                  .....
                  </web-app>
                  ------------------------------------------------
                  2.struts-conf.xml ( placed in WEB-INF\)
                  .......
                  <action-mappings>




                  </action-mappings>
                  .....
                  -----------------------------------

                  3. the jsp page(loginBack.jsp) calling action

                  <%@ page language="java" %>
                  <%@ page import="java.util.*"%>
                  <%@ page import="TSIPack.logic.*"%>
                  <%@ page import="TSIPack.view.*"%>
                  <%@ taglib uri="/WEB-INF/struts-html.tld" prefix="html" %>
                  <%@ taglib uri="/WEB-INF/struts-form.tld" prefix="form" %>
                  <%@ taglib uri="/WEB-INF/struts-bean.tld" prefix="bean" %>




                  ...............
                  .............
                  ................
                  this will have a text user name and password..
                  and a submit button..
                  ------------------------------------------------

                  4. this is the path where i am calling th action servlet
                  -------------------------------------------------------
                  /home/jboss-3.0.0/server/default/deploy/TSI.war/WEB-INF/classes/TSIPack/actions/
                  ----------------------------------------------------

                  currently i am using jboss 3 verson

                  please help me