0 Replies Latest reply on Jul 24, 2002 1:55 AM by G. Griffin

    escape sequences in cookies

    G. Griffin Newbie

      I am trying to move from Tomcat to Jboss-Tomcat. Under Tomcat I developed a simple servlet (no jsp) application that returns a cookie to the client browser. The cookie contains strings of the form:

      abc#xyz$mnl

      When I run Tomcat, the cookie is set and retrieved correctly. However, when I deploy the application under Jboss-Tomcat, the cookie that is set on the client is:

      abc%23xyz%26mnl

      My configuration is Apache + jboss-3.0.0_tomcat-4.0.3, but the problem also occurs using jetty in jboss-3.0.0.
      Also, the problem is problably NOT caused by the Apache link (through mod_jk) because it still occurs when I access Jboss through port 8080 (for both Jetty and Tomcat).

      I was unable to try this with an earlier version of Jboss, so I don't know if the behavior is new to 3.0.0.

      The application being run is identical in all cases, and I can easily switch between having it work and not work just by switching between Tomcat and Jboss.

      Is there some kind of configuration that I need to set to make Jboss-tomcat work like Tomcat?



      There is a separate curious matter that may or may not be related. When I run Jboss behind Apache, any error page returned from Jboss is recieved by my browser as a text page (i.e. the etc. tags are visible on the screen and not interpreted by the browser). However, when I access Jboss directly, it returns the page as HTML, formatted as stand-alone Tomcat does. Is there something different that I need to configure Jboss-Tomcat to return these pages as HTML? Since this problem does not occur when using port 8080 while the cookie escape character one does, I suspect that they are not tied together, but you never know!


      Any help would be appreciated, since without getting the cookie problem fixed I won't be able to use Jboss as my Application Server!

      Thanks.