4 Replies Latest reply on Nov 6, 2002 3:17 PM by mech

    Problems running JBoss with SSL - help?

    Ramin Ziai Newbie

      i am running jboss 3.0 with tomcat and have problems
      to setup ssl. here ist the error i get:

      org.jboss.deployment.DeploymentException: jboss.security:
      service=JaasSecurityManager is not registered.

      to configure ssl i did the following steps:

      1. create keystore:
      keytool -genkey -keyalg RSA -alias tomcat -keystore
      server.keystore

      2. Uncomment the ssl-section in catalinas server.xml

      3. modified jboss-service.xml:

      ***file fragment of jboss-service.xml***

      The SSL domain setup -->




      server.keystore
      changeit














      <!-- SSL/TLS Connector configuration -->









      when i run tomcat alone, ssl is working fine. but not
      in conjunction with jboss.

      thanks for help.

      ramin

        • 1. Re: Problems running JBoss with SSL - help?
          Rodrigo Oliveira Newbie

          I have the same problem did you find a solution?

          • 2. Re: Problems running JBoss with SSL - help?
            mech Newbie

            using newest Tomcat 4.1.12/JBoss3.0.x

            step 1: okay
            (hope you used the same password for keystore and certificate)
            double check: http://jakarta.apache.org/tomcat/tomcat-4.1-doc/ssl-howto.html

            step 2: not necessary if you start the Tomcat/Jboss bundle (only needed for standalone Tomcat)

            step 3: try this file ("tomcat-service41.xml" in /deploy")

            <?xml version="1.0" encoding="UTF-8"?>
            <!-- Set catalina.home to the location of the Tomcat-4.1.x dist.
            The default value is that of the JBoss/Catalina bundle where the
            jakarta-tomcat-4.1.12-LE-jdk14 is included as jboss_dist/catalina
            -->
            <!DOCTYPE server [
            <!ENTITY catalina.home "../tomcat-4.1.x">
            ]>

            <!-- The service configuration for the embedded Tomcat4.1.x web container
            -->








            <!-- The SSL domain setup -->




            YourPathAndNameToKeystore
            YourPasswordIfNotDefault



            &catalina.home;

            <!-- Uncomment this if you want interval snapshot for the
            session clustering.
            interval
            2000
            -->











            <!-- A HTTP Connector on port 8080 -->

            <!-- SSL/TLS Connector configuration -->










            • 3. Re: Problems running JBoss with SSL - help?
              mech Newbie

              using newest Tomcat 4.1.12/JBoss3.0.x

              step 1: okay
              (hope you used the same password for keystore and certificate)
              double check: http://jakarta.apache.org/tomcat/tomcat-4.1-doc/ssl-howto.html

              step 2: not necessary if you start the Tomcat/Jboss bundle (only needed for standalone Tomcat)

              step 3: try this file ("tomcat-service41.xml" in /deploy")

              <?xml version="1.0" encoding="UTF-8"?>
              <!-- Set catalina.home to the location of the Tomcat-4.1.x dist.
              The default value is that of the JBoss/Catalina bundle where the
              jakarta-tomcat-4.1.12-LE-jdk14 is included as jboss_dist/catalina
              -->
              <!DOCTYPE server [
              <!ENTITY catalina.home "../tomcat-4.1.x">
              ]>

              <!-- The service configuration for the embedded Tomcat4.1.x web container
              -->








              <!-- The SSL domain setup -->




              YourPathAndNameToKeystore
              YourPasswordIfNotDefault



              &catalina.home;

              <!-- Uncomment this if you want interval snapshot for the
              session clustering.
              interval
              2000
              -->











              <!-- A HTTP Connector on port 8080 -->

              <!-- SSL/TLS Connector configuration -->










              • 4. Re: Problems running JBoss with SSL - help?
                mech Newbie

                Don't put this data from step 3 into jboss-service.xml.
                Instead use the tomcat-service41.xml file in the /deploy directory.