0 Replies Latest reply on Aug 23, 2002 12:34 PM by Ron Siewert

    Servlet exception: error instantiating servlet class

    Ron Siewert Newbie

      I am trying to deploy a struts app and keep getting this error:
      10:25:38,893 INFO [Engine] default: init
      10:25:38,894 INFO [Engine] StandardWrapper[/testjboss:invoker]: Loading container servlet invoker
      10:25:38,894 INFO [Engine] invoker: init
      10:25:39,535 INFO [Engine] StandardWrapper[/testjboss:action]: Marking servlet action as unavailable
      10:25:39,544 ERROR [Engine] StandardContext[/testjboss]: Servlet /testjboss threw load() exception
      javax.servlet.ServletException: Error instantiating servlet class com.bostonbred.services.struts.ActionServlet
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:895)

      I've upgraded to jboss-3.0.1RC1_tomcat-4.0.4 as some have indicated in this forum but to no avail. I haven't seen anybody else having this problem and the deploy seems to be just dropping it into the default/deploy directory (using an .ear file). I've posted three times before but have not gotten any replies. Has anybody had any similar problems or experienced similar behavior? If so would you please reply. Doesn't jboss know where it deployed my .war? My classes are deployed in: M:\usr\local\jboss3.0.1\jboss-3.0.1RC1_tomcat-4.0.4\catalina\work\MainEngine\localhost\testjboss\WEB-INF\classes\com\bostonbred\services\struts. Isn't this where they are supposed to be? Why isn't jboss looking where it placed the classes? PLEASE HELP...