0 Replies Latest reply on Sep 27, 2002 1:07 PM by Andrew May

    Problem with resource-ref

    Andrew May Newbie

      I'm trying to port an application to JBoss (3.0.1, Jetty), and I'm having a problem with a resouce-ref entry in web.xml for a javax.mail.Session.

      I've created the mail session in mail-service.xml and that seems to be deployed correctly, and put the entry in jboss-web.xml to map the resource-ref to the location in JNDI.

      When I try to deploy the WAR (as part of an EAR) I get exceptions like:
      org.jboss.deployment.DeploymentException: ejb-ref: search/ejb/AnnotationService, no ejb-link match, use jndi-name in jboss-web.xml

      without the resource-ref it all deploys and runs fine (including the above EJB).

      The original application was J2EE 1.2 and therefore Servlet2.2. I've tried using a 2.2 deployment descriptor and a 2.3 one. I've also tried using resource-env-ref instead of resource-ref (I'm not sure I understand the difference between these two), but I always get the same error.

      Any ideas? At this point I'm tearing my hair out, and there wasn't much of that left in the first place.

      -Andrew