0 Replies Latest reply on Dec 24, 2002 7:12 AM by Andrzej Roszkowski

    JBoss 3.0.4/Jetty + Struts 1.0.2 problems

    Andrzej Roszkowski Newbie

      Hi

      during Struts sample app deployment I got this:
      Caused by: java.lang.NoClassDefFoundError: javax/servlet/http/HttpServlet
      at java.lang.ClassLoader.defineClass0(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
      at java.net.URLClassLoader.defineClass(URLClassLoader.java:250)
      at java.net.URLClassLoader.access$100(URLClassLoader.java:54)
      at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:186)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:265)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
      at org.jboss.mx.loading.UnifiedClassLoader.loadClassLocally(UnifiedClassLoader.java:247)
      at org.jboss.mx.loading.UnifiedLoaderRepository3.loadClassFromClassLoader(UnifiedLoaderRepository3.java:208)
      at org.jboss.mx.loading.LoadMgr.beginLoadTask(LoadMgr.java:119)
      at org.jboss.mx.loading.UnifiedClassLoader3.loadClass(UnifiedClassLoader3.java:140)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:292)
      at java.net.FactoryURLClassLoader.loadClass(URLClassLoader.java:566)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      at org.mortbay.http.ContextLoader.loadClass(ContextLoader.java:216)
      at org.mortbay.http.ContextLoader.loadClass(ContextLoader.java:200)
      at org.mortbay.http.HttpContext.loadClass(HttpContext.java:1302)
      at org.mortbay.jetty.servlet.Holder.start(Holder.java:161)
      at org.mortbay.jetty.servlet.ServletHolder.start(ServletHolder.java:204)
      at org.mortbay.jetty.servlet.ServletHandler.initializeServlets(ServletHandler.java:444)
      at org.mortbay.jetty.servlet.WebApplicationHandler.initializeServlets(WebApplicationHandler.java:163)
      at org.mortbay.jetty.servlet.WebApplicationContext.start(WebApplicationContext.java:492)
      at org.mortbay.j2ee.J2EEWebApplicationContext.start(J2EEWebApplicationContext.java:85)
      at org.jboss.jetty.Jetty.deploy(Jetty.java:414)
      at org.jboss.jetty.JettyService.performDeploy(JettyService.java:243)
      at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:300)
      at org.jboss.deployment.MainDeployer.start(MainDeployer.java:807)


      it is very strange to me because other non-struts Servlets are working ;) any ideas?