0 Replies Latest reply on Jan 31, 2003 7:34 AM by Tim Hague

    Classloaders and redeployment

    Tim Hague Newbie

      I've been wrestling with the classloading issues in JBoss 3.2.0 and 3.0.6 + Tomcat 4.1.18 for a week now.

      I've got multiple ear files, some with a single war and some with multiple wars.

      I've now got to the point where I can deploy everything OK and it all works - the first time. I then undeploy everything, redeploy it all and get classloader problems when running again. If I stop JBoss and manually clean all the temp directories, restart and redeploy it all works fine again.

      The problem appears to be with the war library files, as documented in a number of other threads on here (see http://www.jboss.org/modules/bb/index.html?module=bb&op=viewtopic&t=forums/ for example).

      So far I've tried:
      - Putting all my war library files in Tomcat4.1.x\server\lib. This has come closest to working but I don't like the solution at all. I can deploy and run on a clean JBoss fine but I still have some problems running after problems.
      - Packaging the war library files in the ear and referring to them in a META-INF\MANIFEST.MF in the war. Again I can deploy and run fine the first time, have quite a few problems running after redeployment again.

      The two solutions above have been suggested by other people on here and solved my initial deployment and running problems. Now I'm stuck again. I don't want to have to restart JBoss every time I redeploy - and I shouldn't have to.

      Does anyone have any ideas what might be going wrong this time?
      Is there any way of forcing JBoss to reload everything from scratch every time you deploy?
      Any help anyone can offer would be much appreciated. At the moment I can't afford to upgrade my version of JBoss at all - I'm stuck on 3.0.2...