0 Replies Latest reply on Aug 6, 2003 9:33 AM by adamlevine

    Sessions not using cookies, only URL rewrite

    adamlevine Newbie

      I recently changed my struts library from 1.0 to 1.1. I also upgraded my J2EE libs from 1.2.1 to 1.3.1. I'm using JBoss/Jetty 3.0.7.

      Since the change, my application will no longer do session control using a cookie -- only URL rewrites. I changed nothing in the jbossweb.sar or any other configuration changes.

      On the same server I'm running a Jive instance, which is using cookies just fine, and a Jira eval, which is also running w/o a problem.

      The fact that 2 other apps are using cookies for session control makes me believe it's not so much a container configuration issue.

      I can't help but wonder if it's an issue with Struts 1.1, the newer EE libraries, or if I'm just a complete putz and missing a jboss/jetty configuration (even tho cookies were working just fine before).

      I've tried a clean install of 3.0.7, a clean install of 3.0.8. I've tried using the cookie-specific config parms from jbossweb.sat/webdefault.xml in my web app's web.xml, specifically setting the realm to "/" instead of leaving it just as the default "/" in the webdefault.

      I've used several browsers (links, lynx, IE), and from several different machines. No session cookie is being set.

      If I telnet to the web app and do a manual GET, I see this:

      Set-Cookie: JSESSIONID=5k1e1ucimua6;Path=/web-client;Domain=
      Set-Cookie2: JSESSIONID=5k1e1ucimua6;Version=1;Path=/web-client;Domain=;Discard

      Only since I tried the 3.0.8 install have I seen the second cookie with the Discard tag.

      I've tried posting this question on the struts lists, and all fingers point to the container. I've looked on the JEtty pages, and all things ask about NOT using cookies (so I tried using the reverse settings).

      I'm lost. It was working before the library changes. I'm calling HttpRequest.getSession() to retrieve/create the session.

      Any thoughts? I'm going rapidly bald. Thanks for any help.