2 Replies Latest reply on Nov 17, 2003 10:02 AM by Joe Fraser

    JasperException: Unable to compile class for JSP

    Dennis O'Flynn Newbie

      Q: Why can't JBoss w/ Tomcat be installed in a path that has spaces?

      I'm trying to install JBoss on a WinXP machine. The base locaiton for the install is: "C:\Program Files\JBoss". In this folder, I have unzipped the following versions of JBoss:
      1) jboss-3.2.1 (w/ Jetty)
      2) jboss-3.2.1_tomcat-4.1.24
      3) jboss-3.2.2 (w/ Tomcat)

      The system environment variable JAVA_HOME is properly set to where JDK 1.4.1_02 is installed.

      When I run JBoss 3.2.1 (w/ Jetty), I am able to access the JMX Console.

      However, when I run either JBoss 3.2.1 or JBoss 3.2.2 w/ Tomcat, I cannot access the JMX console (or any other JSP). The browser displays the following text.

      org.apache.jasper.JasperException: Unable to compile class for JSP

      An error occurred at line: -1 in the jsp file: null

      Generated servlet error:
      [javac] Compiling 1 source file
      [javac] javac: invalid flag: C:\Program

      Please note the invalid flag of "C:\Program". This is the beginning of the base path of where JBoss was installed (C:\Program Files\...).

      It appears that JBoss w/ Tomcat does not properly handle a space in its installation path. Since this works with stand-alone Tomcate, I assume it is an issue with JBoss.

      I cannot force the installation of JBoss into a path that does not contains spaces since the installation location is user specified.

      Any help resolving this issue would be greatly appreciated!